Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I'm used to using Windows Server 2003 but decided to get a Vista Web Edition for IIS7 and to run our MVC applications on.

I have installed copSSH that I use for SFTP, and when I upload my files I am unable to change persmissions or take ownership or anything when logged in as an administrator.

When I try to go to permissions I get: The permissions on uploads are incorrectly ordered, which may cause some entries to be ineffective. And all permissions are the grayed out.

I have tried to use icacls to reset ownership and also tried to give myself full control through icacls however all attempts are met with an access is denied message and failed processing 669 files. All I wish to do is set up write and delete permissions on an upload folder for a CMS systems admin area, but I am a week into looking into this and I am still no wiser.

Please could someone give some sound advice so i can get this running smooth

thanks

p.s i have added the copSSH notes as i think that when i SFTP the files to the server, this may somehow have some involvement in messing up permissions

share|improve this question
    
I assume you mean server 2008 web edition, rather than vista web edition? –  Sam Mar 18 '10 at 14:27
    
yes wasent sure if it was 2008 or not its also SP2 –  minus4 Mar 18 '10 at 14:34
    
as an update i copied all the files onto another folder and i get control over permissions again, i also checked to make sure that the FTPLogin is not part of administrators, still puzzled –  minus4 Mar 18 '10 at 17:38
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.