Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

We have a ProCurve Switch 2810-48G (J9022A).

We need to disable auto negotiation on two ports and manually configure them to be full duplex gige ports.

From the web GUI, Configuration Tab, Port Configuration sub tab, I am only presented with the option to configure the port as Auto - 1000. I take this to mean, auto negotiate duplex, manually configure the speed to be gige.

How do I manually configure the port such that it is manually configured to use full duplex, 1000 mbs?

share|improve this question
    
From the manual, auto "negotiates with the port at the other end of the link for other port operation features" and has nothing to do with negotiating full/half duplex (as it doesn't support 1000/half duplex, only 1000/full). –  Dave Jul 9 '10 at 5:19
add comment

2 Answers 2

Use the command line interface instead. When you're logged in as a manager, use the "config" command, then set the parameters for the ports you want (I just used c1,c2 as the example):

Procurve# config
ProCurve(config)# interface ethernet c1,c2 speed-duplex 1000-full

Manuals for the 2810 are here, the Management and Configuration Guide covers the web, menu, and command line interfaces in detail.

share|improve this answer
    
+1, just do it from the command line! –  James Mar 18 '10 at 17:49
    
The trouble is, when I try to set 1000-full from the CLI (as described) I get the following error: Value 1000-full is not applicable to port 39 The exact commands I have entered are: config interface 39 speed-duplex 1000-full BTW: speed-duplex auto-1000 works. –  SvrGuy Mar 18 '10 at 22:17
add comment

Here is the semi-official word from HP. Although meant for the 3500 and 5400 series switches, based on the language it sounds like it would apply to all HP products:

Q: Why can't I configure the ProCurve 3500yl/5400zl 10/100/1000 Base-T ports for 1000 Full-Duplex operation?

The full-duplex setting is not required by the IEEE 802.3ab 1000 Base-T standard. In order to be compliant with the standard, devices must be able to auto-negotiate to 1000 full-duplex when the port is configured to "auto". If your device does not operate at 1000 full-duplex with the switch port set to "auto", check your device driver and cable, or contact technical support for your product(s).

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.