Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

On Windows Server 2008 R2 with the User Account Control Settings at the third highest level when you start explorer 'as administrator' it doesnt appear to actually grant administrative rights to the process. Is there a way to leave UAC at that level AND be able to start an explorer process as a 'real' administrator?

share|improve this question
    
Just to be clear, UAC at the "third highest level" is the default in 2008 R2. –  Ryan Bolger Mar 18 '10 at 19:32

4 Answers 4

Back in 2008 pre-R2, I used to do this by running explorer from an elevated command prompt. This doesn't seem to work anymore with R2.

The only way I've found to do it in R2 so far is by killing the existing non-elevated explorer instance first. Once the non-elevated explorer is gone, the elevated version will launch successfully from wherever you launch it.

I'm curious to see the other answers this generates, because killing explorer is messy. The only other option I know of is to login with the actual "administrator" account since UAC doesn't apply to it.

share|improve this answer

The following procedure works for me but not the shortest one:

  1. Make sure that account you are logging in as has the appropriate credentials for the task you are trying to accomplish, in my case, I needed to be part of the domain builtin\Administrators group to manage my DC. I made sure to add my account to this group first.
  2. Next Right-click black Command Prompt icon on start menu.
  3. Select Run as administrator
  4. Type in the account credentials you created above. Unfortunately, you will need to type them in again.
  5. Next use the following command: runas /user:domain\username "explorer /separate"
  6. It should prompt for your password in the command line, enter your password. Unfortunately, it will not automatically launch windows explorer, you will still need to type the command.
  7. Now type either one of the following commands while still in the command line:
  8. "explorer ." or start .

This seemed to work well for me, let me know otherwise and I hope that it helps someone.

I pulled the information from the following MS forum: http://answers.microsoft.com/en-us/windows/forum/windows_vista-security/how-to-start-windows-explorer-as-administrator/a3cfdd52-695d-46b0-a617-1c9128addf01

share|improve this answer

Try to set "Launch folder windows in separate process" option in folder options, to see if that does the trick.

share|improve this answer

You can't, if you're running another copy of explorer.exe (like, say, the desktop shell). MS removed the ability to do this altogether from Vista, and it hasn't made it back in yet. Launch folder windows in a separate process doesn't do the trick anymore like it did in XP/2003.

Your options:

  • Exit all instances of the shell. If you hold down Ctrl+Shift and Right-Click on an empty area of the Start Menu, the context menu will have an Exit Explorer entry. That's significantly less messy than killing explorer.exe via some other method (e.g. Task Manager, psKill, etc.). One can do the same thing in XP by going to the shutdown dialog and holding down Ctrl+Alt+Shift while canceling the dialog.
  • Get a 3rd party file manager. The inability to horizontally scroll the tree in the new Explorer makes this particularly attractive if you have any significant folder hierarchies.
  • Have "administrative" user accounts that log in without UAC by default. I'm not sure if this is possible, but Microsoft is doing it with the Administrator account. Even if it worked, this involves logging out and back in. Not exactly great.
  • Disable UAC. :-)
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.