Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

With VMWare it works fine and I can run multiple cores on a VMWare image. With VirtualBox I can only run 1 CPU on a image. Its annoying.

Why does Virtualbox not work the same as VMware in this respect?

My CPU is:

XEON 3.00GHz Intel 90nm 2MBCache QUAD CPU x14 Socket 604 mPGA Family 15 Model 4(04) Stepping 3 Revision 05 MMX SSE3 XD

SIV.exe tells me:

No virtual machine extensions x86 with 64-bit support
NO IA64 support
MPS but with NO MCP
2 physical processors, 2 cores, 4 logical processors

I tried manually setting my # of CPU's and it causes this error which I cannot reverse without restarting my whole computer.

C:\Program Files\Sun\VirtualBox>VBoxManage modifyvm XPSP3 --cpus 2
Sun VirtualBox Command Line Management Interface Version 3.1.4
(C) 2005-2010 Sun Microsystems, Inc.
All rights reserved.
share|improve this question
3  
You might be better off asking Sun why they developed their product a particular way. –  Zoredache Mar 18 '10 at 23:12
    
Superuser may be a better fit for this question IMO. –  Chris Lercher Mar 18 '10 at 23:23
    
@chris - agreed, VirtualBox is a client-side virtualisation program –  Mark Henderson Mar 18 '10 at 23:24
    
I disagree only because “client-side” can still be something used in the enterprise. Someone running a dual proc Xeon system is a bit less likely to be a home user as well. –  Dave Mar 19 '10 at 0:59
    
@Dave, I agree but I also find it hard to decide whether to cast a close vote for it being off-topic, subject & argumentative or not a real question. –  John Gardeniers Mar 19 '10 at 3:37
show 2 more comments

2 Answers 2

I don't know, if this is because of your XEON processor. I can run two cores inside VirtualBox on my Core2Duo (Host: MacOS; Guest: Linux).

Did you enable VT-x/AMD-V (in Settings/System/Acceleration)? Did you install the VirtualBox guest additions in your guest system (Devices/Install Guest Additions...)?

share|improve this answer
    
the Acceleration options are checked and greyed out and so I cannot change them. I couldn't find the "Devices/Install Guest Additons" thing that you refer to... –  djangofan Mar 19 '10 at 20:04
    
The system on which I've enabled the two cores is a Ubuntu 9.10 Desktop (in contrast, my server instances all run with 1 core, so I don't know). I have no idea, what it means that your "VT-x/AMD-V" setting is grayed out - I don't remember reading anything about that in the VirtualBox documentation. But: The "Devices/Install Guest Additions" you should find in the menu (not in the settings dialog), as soon as the VM is started. Keep in mind, that I installed those on a desktop system, and I think I remember, I had problems installing them on a headless environment. But they solve many problems. –  Chris Lercher Mar 19 '10 at 20:32
    
its version 3.14. yep, i had already installed guest additions, which from VMWare experience is one of the first things I do. doesn't make a difference as far as I can tell. –  djangofan Mar 23 '10 at 21:46
    
Maybe these hardware virtualization extensions could be turned off in the BIOS of your PC (?) - Unfortunately I can't check this here, since my Mac doesn't have BIOS settings. –  Chris Lercher Mar 23 '10 at 22:44
    
good idea. the bios wouldnt let me enable it. the bios just says "multiple cpu capability=no" but it says yes to hyperthreading. –  djangofan Mar 23 '10 at 23:22
show 1 more comment

How do you know you can only use one CPU? When you try to create a virtual machine with more, do you get an error? What about if you use VBoxManage modifyvm and try to set the number of CPUs manually?

share|improve this answer
    
no error. the UI just doesn't give me the option to select more than one cpu... its greyed out. –  djangofan Mar 19 '10 at 19:57
    
Which version of VirtualBox do you have? I believe you need at least 3.0 to do guest SMP. Also, try using the command line tools: "VBoxManage modifyvm <vmname> --cpus #" where # is the number of CPUs you want to use. –  Dave Mar 20 '10 at 8:28
    
The VBoxManage thing didn't help. It changed my CPU but the VM wouldn't start, complaining about not having VT-x support or something. –  djangofan Mar 23 '10 at 22:01
    
It sounds like VirtualBox doesn’t support multiple virtual CPUs on your processor. I know it works on all modern machines I’ve tried, but if your processor is socket 604, it’s quite old. Have you tried creating a new clean VM as a last resort? As another option, set it to a different OS like Windows 2003 instead of Windows XP. –  Dave Mar 24 '10 at 8:30
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.