Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have a new Windows 2008 server with IIS7. When I connect to the ftp in active mode, it works fine. In passive mode, it connects, but then times out trying to get the directory listing. I tried disabling both firewalls, but it didn't help. I've tried this with difference client machines and different ftp client software, with no change. Any ideas?

share|improve this question
up vote 3 down vote accepted

In the command prompt of the server, enter these two commands to open the firewall:

First command:

netsh advfirewall firewall add rule name="FTP (non-SSL)" action=allow protocol=TCP dir=in localport=21

Second command:

netsh advfirewall set global StatefulFtp enable

In Amazon EC2, you also have to set up a security group to open the passive ports, such as 1025 to 7000.

share|improve this answer

I had the same issue using filezilla ftp server. Active connections worked but passive didn't... I solved it by adding FileZilla server.exe ( in the program files folder ) to the "exceptions list" of windows firewall. Then everything worked. Just goes to show you ... RTFM.

share|improve this answer

You can actually try following the article Out Of Band FTP 7 shows "Operation timed out".

share|improve this answer

I'd disable the IIS FTP Server and switch to single-port SFTP instead using "NULL FTP Server" . It's more secure and only requires a single port to be opened unlike the old style FTP protocol.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.