Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

We have a ProCurve Switch 2810-48G (J9022A).

We need to disable auto negotiation on two ports and manually configure them to be full duplex gige ports.

From the web GUI, Configuration Tab, Port Configuration sub tab, I am only presented with the option to configure the port as Auto - 1000. I take this to mean, auto negotiate duplex, manually configure the speed to be gige.

From the CLI when I try to set 1000-full I get the following error: Value 1000-full is not applicable to port 39 (or whatever port I try) The exact commands I have entered are:

config interface 39 speed-duplex 1000-full

BTW: speed-duplex auto-1000 works ( I also tried full-1000 and that did not work either)

How do I manually configure the port such that it is manually configured to use full duplex, 1000 mbs?

share|improve this question

1 Answer 1

up vote 1 down vote accepted

There is no half-duplex in GigE - so set them to 1000-auto (its the same as 1000-full), also being GigE ports they should Autoneg perfectly fine removing the need to hardcode them at 1000, the days of vendors ended with GigE, Auto negotiation is a requirement for using 1000BASE-T according to the specs - as GigE works in a Master/Slave setup and they have to negotiate that. Why are you having to hardcode their speeds ?

share|improve this answer
    
That is what I though, actually. I managed, however, to convince myself that I was imagining things though: A CCIE in a data center where we are doing an installation asked us to lock the port to 1000/full duplex and disable auto negotiation and there was that 1000-full option in the documentation. HP support got back to me and confirmed its AUTO ONLY for gige Perhaps cisco gear has some proprietary mode that does not auto-neg anything? –  SvrGuy Mar 19 '10 at 18:36

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.