Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I need to send a request to CUPS server with the specific request-user parameter - remote_user instead of local_user. How should I set the local CUPS server?

share|improve this question

2 Answers 2

According to the CUPS release notes, support for specifying a different username was added in CUPS 1.6b1:

  • CUPS now supports a User directive in client.conf and the CUPS_USER environment variable for overriding the default username (STR #3114)

The Ubuntu bug report below (I can't make it a link due to ServerFault limits) is another place to look for information and workarounds for pre-CUPS 1.6b1, although the workarounds are not very practical.

bugs.launchpad.net/common-print-dialog-gtk/+bug/856776

share|improve this answer

If you print using this command:

lp -d yourprintername -U yourusername /path/to/file

you'll find requesting-user-name="yourusername" in CUPS' error_log file (but your cupsd.conf needs to be edited to use LogLevel debug for that message to show up).

If you want to force a default option for all users, run this command as root:

lpoptions -d yourprintername -o requesting-user-name=someusername

[Note: some versions of CUPS seem to mix up 'job-originating-user-name' and 'requesting-user-name'. So you know if my suggestion doesn't work for you...]

share|improve this answer
    
No. I want to use from desktop. Running this command from root does not affect the default on my system as well. –  Maciej Piechotka Aug 7 '10 at 14:41
    
@Maciej: had forgotten to add the command. –  Kurt Pfeifle Aug 7 '10 at 15:16
    
I have 1.4.4. Do you know which does not? –  Maciej Piechotka Aug 7 '10 at 16:07

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.