Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I would like to use all my monitors for the remote session (an option in RDC dialogue) if I connect (from Windows 7) to the one server with Windows 2008 R2 it works OK (I have remote connection on my all monitors) when do I connect to the another machine with Windows 7 it just wound not use all my monitors, but just one (full screen mode).

What do I missing here? Some setting on the Windows 7 RDP server?

Basically my question is:
How to establish multimonitor RDC connection from Windows 7 to another Windows 7 running computer?

share|improve this question
    
    
Sorry this is not the same question nor the "exact duplicate". I am questioning why multimonitor setting is not working not how to establish that kind of connection ... –  Peter Stegnar Mar 21 '10 at 9:58
    
You could saw this by accepted answer, that my and the other question are totally different. –  Peter Stegnar Mar 21 '10 at 10:05
1  
Yes I pondered a bit after I threw my vote - I have voted to reopen, this question is much more specific (we could give the title some work though ;) –  Oskar Duveborn Mar 21 '10 at 10:20
    
Ok. So others, please vote to reopen this question. –  Peter Stegnar Mar 21 '10 at 10:48

3 Answers 3

up vote 6 down vote accepted

You need Windows 7 Ultimate or Enterprise at the end-point to support multiple terminal services displays (or any edition of Windows Server 2008 R2).

share|improve this answer
    
Yes! This is it. I have professional version and that why multmonitor RDC is not working. windows.microsoft.com/en-US/windows7/… –  Peter Stegnar Mar 21 '10 at 10:04

Well, first:

  • THERE IS NO WINDOWS 7 SERVER, dude. Seriously. As such you can not have a setting on it.

  • Windows 7 is not a server os, so you should not run it on a server ;) That said, it also works if you are connecting to windows 7 workstations remotely from a Windows 7 workstation, ad I do that a lot (virtualized desktop here for certain applications).

  • If your servers run a OS before 2008 R2.... then you basically are out of luck. As in: the SERVER side of multi monitor support was added with R2. A 2008 server simpy can not serve multiple monitors.

share|improve this answer
    
Who said Windows 7 Server? I just said I have a server with Windows 7. Windows 7 can also "serve". We agree on that right? –  Peter Stegnar Mar 21 '10 at 8:23
1  
wow tomtom, you can't have read the question at all –  Chopper3 Mar 21 '10 at 8:25
    
I did. Before the edit. –  TomTom Mar 21 '10 at 9:47
    
TomTom you are lying, sorry: I edited only that I have ADDED the bolded question (because of your answer at first place). Come on TomTom? –  Peter Stegnar Mar 21 '10 at 9:53
    
Proof: img222.imageshack.us/img222/3107/questionrevision.jpg as I said, I have only ADDED a question summary. TomTom: I can believe you said that! You lost all credibility! –  Peter Stegnar Mar 21 '10 at 10:11

Check the group policy setting "Computer Configuration, Administrative Templates, Windows components, Remote Desktop Services, Remote Desktop Session Host, Remote Session Environment, Limit maximum number of monitors" on your Windows 7 machine.

share|improve this answer
    
I did not have this setting enabled. I have set maximum monitors to 3 as I need it. But it is not working. Should I restart a computer? –  Peter Stegnar Mar 21 '10 at 9:02
    
Yes, you almost certainly need to restart. –  Zoredache Mar 21 '10 at 9:05
    
I have restarted the computer. It still does not working, but at "Limit maximum number of monitors" setting help I saw, that exists another related setting "Maximum monitors per session". Does anyone know where it is? (it should be in the tsconfig.msc, but this is only on Windows Server OS) –  Peter Stegnar Mar 21 '10 at 9:28

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.