Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I have a Win 2008 R2 Data Center machine, and when I added the Hyper-V role, I got the following errors:

'Hypervisor' driver required by the Virtual Machine Management service is not installed or is disabled. Check your settings or try reinstalling the Hyper-V role.

Hyper-V launch failed; Either VMX not present or not enabled in BIOS.

ANy help would be appreciated as I am a n00b to the server world.

EDIT: This was a good resource: https://support.dell.com/support/edocs/software/HyperV/en/sov/sova00.pdf

Thanks.

share|improve this question
    
As a note to others, your BIOS MUST support the features Hyper-V needs, otherwise you can't start any VMs. You should be able to run Windows Virtual Server or VMWare Server. But YMMV on the performance of those products. –  Nathan Adams Dec 4 '10 at 14:54

3 Answers 3

up vote 3 down vote accepted

Well, check what the error says.

Hyper-V runs only with Hardware virtualization. For that...

  • The hardware must support virtualization AND
  • The BIOS must enable it

Check those two things - that your BIOS allows virtualization, and that the server supports it to start with.

share|improve this answer
    
What is the 'Hypervisor' driver and where does it come from because it would seem like that would be managed too by installing the HyperV role... –  Brian Mains Mar 22 '10 at 17:16
    
It is the driver running hyper-v. And it GETS installed, it just can not start if your hardware does not support virtualization or your bios blocks it. That simple. So, check your hardware and make sure your bios has virtualization on. –  TomTom Mar 22 '10 at 18:05
    
Got the Virtualization enabled, but still get the Hypervisor error.... –  Brian Mains Mar 23 '10 at 23:39

In order to use Hyper-V, make sure the Virtualization Technology and Data Execution Prevention are ENABLED in the BIOS. After enabling them, completely shutdown your pc or laptop. Simply rebooting the system will not work for some hardware.

This worked for me using HP 8710p.

share|improve this answer

In my case, my motherboard did not have this feature. I had to go with Oracle's free VirtualBox.

http://www.virtualbox.org

Hopefully this points someone in a direction other then the brick wall they just hit finding out that VMWare and Hyper-V require you to have a feature available in your bios. ;)

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.