Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I am trying to set up a CentOS 5.4 box to use a static IPv4 address, while getting a dynamic IPv6 address at boot time.

I have only one interface, apart from the loopback interface, eth0. It has a static v4 and internet connectivity (I can SSH in). However, it doesn't get an IPv6 by default.

I have enabled IPv6 in /etc/sysconfig/network and I have added IPV6INIT=yes to the config in /etc/sysconfig/networking/devices/.

If I use dhcp6c it does get a valid IPv6 address, but the main question is how do I configure it to get one at boot-time?

share|improve this question
up vote 3 down vote accepted

In the end, the answer is simple. One has to put several options in the /etc/sysconfig/networking/devices/ files.

The first is IPV6INIT=yes, obviously, to enable IPv6 on that interface. Now, to enable DHCPv6 so you get an adress at boot time, you also have to add DHCPV6C=yes. That fixed it for me.

So you have at least these two lines:


That's it :-)

share|improve this answer

The first step would be to check if the interface is getting the default link-local fe00:* and any-castff00: addresses.

If you are not using dhcp6 (and i personally prefer not to) then you need to configure the router to broadcast teh default routs etc. perhaps you have already done this?

You can use the radvdump program to verify that the router is sending advertisements and they are getting to this box.

share|improve this answer
It does get a link-local address, this is not the problem. Due to the infrastructure of the network I need dchp6c. There is no ra daemon running on our network. – Zsub Mar 27 '10 at 16:48
if you see the link local addresses then ip6 is basically working. The RA stuff wont help you, though I will leave it in for others who come across this question. – Arthur Ulfeldt Mar 31 '10 at 20:45

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.