Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

So, as the name suggest I'm trying to mount a ISO from a network share using the UNC path to a HYPER-V R2 Cluster.

This is a pure Demo / test case setup with:

2x HYPER-V R2 1X NAS/iSCSI CSV Cluster

Management is happening through the MMC with RSAT tools.

So what i've done so far is:

Set up the cluster and configure Quorum, add CSV Shares and disks, set up 1 Virtual Machine on the Hyper-1 node.

What i'm trying to do is, you go to settings ---> DVD Drive ---> use network location ----> Pick ISO file and press "apply".

Error I'm getting is either "User account does not have rights to mount iso".

I changed that or stopped getting that message when I went to the HYPER-V Node settings and tabbed on:

"Use Default Credentials Automatically".

Now I stopped getting the "user does not have right..." message but I get the following:

  • Error applying DVD Drive Changes

Failed to remove device microsoft synthetic DVD Drive:" the specified network resource or device is no longer available"

I've google'd the problem but am unable to find a solution. Anyone here able to help me out ?

Much abbliged !

share|improve this question

3 Answers 3

up vote 2 down vote accepted

You have to allow delegation to the Hyper-V servers. Instructions here from MPECS.

share|improve this answer
    
right so... More problems. I've been trying further to get it working but after doing most of what that link said I ran into a problem... we run a domain functional level of 2000, not 2003 (which is the domain functional level you need to get all the delegation options to show...) So now I'm stuck with all the share / NTFS permissions set, Delegation is on, but I can't specify it for CIF since its a domain functional level of 2000, not 2003 –  Entity_Razer Mar 24 '10 at 13:46
    
If you still have Windows 2000 Domain Controllers it's time to upgrade. Support for Win2k ended a while ago and that's a timebomb waiting to happen. If you don't have Win2k DCs then you just need to raise the DC functionality. support.microsoft.com/kb/322692 –  Chris S Mar 25 '10 at 15:47
    
We are swapping over to win2K3 Functional levels, but aren't fully converted yet, so for now, for legacy reasons we need to keep the Domain functional level at 2K. –  Entity_Razer Mar 26 '10 at 10:11

can you just add the machine$ account the shared resource? haven't tried this lately but I think it works just fine.

share|improve this answer
    
That does not work. Read the instructions in my post. –  Chris S Mar 25 '10 at 15:44
    
works fine! this also works if you want to use a unc path for a quorum device, thus allowing guest level clustering without iscsi! –  tony roth Mar 25 '10 at 17:20
    
You must have something else configured in your environment that allows this. The Hyper-V service by default does not have access to the machine$ account. This is why you have to set delegation to allow Hyper-V to use that account (in this case for CIFS). –  Chris S Mar 28 '10 at 13:54
    
yea I check all settings they are default and 2003 native mode, No delegation defind etc. Can't figure out why its working but it does! Also the hyper-v process runs as "local system" which does have access to the machine$ account. The one issue that I see people run up against is that the share has domain users but that does not include domain computers. –  tony roth Mar 30 '10 at 15:38

Check that page for the Shared ISO configuration in VMM: http://www.server-talk.eu/2009/09/29/how-to-virtual-machine-mananger-fur-shared-iso-image-konfigurieren/

share|improve this answer
    
That's the same solution as my answer, except in German (I think). –  Chris S Jul 13 '10 at 19:51

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.