Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

again me, i just dont get why i m getting this message, when i try to connect my ftp server thorugh my wan address (112.135.26.115) its saying me, 530 user access denied

but when i give the same data to http://ftptest.net the result is as follows...

Status: Resolving address of 112.135.26.115

Status: Connecting to 112.135.26.115

Status: Connected, waiting for welcome message

Reply: 220-FileZilla Server version 0.9.34 beta

Reply: 220-written by Tim Kosse (Tim.Kosse@gmx.de)

Reply: 220 Please visit http://sourceforge.net/projects/filezilla/

Status: CLNT http://ftptest.net on behalf of 112.135.26.115

Reply: 200 Don't care

Status: USER saravana

Reply: 331 Password required for saravana

Status: PASS *********

Reply: 230 Logged on

Status: SYST

Reply: 215 UNIX emulated by FileZilla

Status: FEAT

Reply: 211-Features:

Reply: MDTM

Reply: REST STREAM

Reply: SIZE

Reply: MLST type*;size*;modify*;

Reply: MLSD

Reply: AUTH SSL

Reply: AUTH TLS

Reply: UTF8

Reply: CLNT

Reply: MFMT

Reply: 211 End

Status: PWD

Reply: 257 "/" is current directory.

Status: Current path is /

Status: TYPE I

Reply: 200 Type set to I

Status: PASV

Reply: 227 Entering Passive Mode (112,135,26,115,43,9)

Status: MLSD

Reply: 150 Connection accepted

Listing: type=dir;modify=20100322113235; it_is_working!_Andrejs_Cainikovs_from_serverfault.com

Listing: type=file;modify=20100322110559;size=5; New Text Document.txt

Reply: 226 Transfer OK

Status: Success

can anyone say why this happens to me? please im trying the whole day!!

here is the log from my local access through filezilla client

    Status: Connecting to 127`enter code here`.0.0.1:21...
Status: Connection established, waiting for welcome message...
Response:   220-FileZilla Server version 0.9.34 beta
Response:   220-written by Tim Kosse (Tim.Kosse@gmx.de)
Response:   220 Please visit http://sourceforge.net/projects/filezilla/
Command:    USER saravana
Response:   331 Password required for saravana
Command:    PASS **********
Response:   230 Logged on
Command:    SYST
Response:   215 UNIX emulated by FileZilla
Command:    FEAT
Response:   211-Features:
Response:    MDTM
Response:    REST STREAM
Response:    SIZE
Response:    MLST type*;size*;modify*;
Response:    MLSD
Response:    UTF8
Response:    CLNT`enter code here`
Response:    MFMT
Response:   211 End
Status: Connected
Status: Retrieving directory listing...
Command:    PWD
Response:   257 "/" is current directory.
Command:    TYPE I
Response:   200 Type set to I
Command:    PASV
Response:   227 Entering Passive Mode (127,0,0,1,43,10)
Command:    MLSD
Response:   150 Connection accepted
Response:   226 Transfer OK
Status: Directory listing successful
share|improve this question
add comment

2 Answers

up vote 0 down vote accepted

Is the FTP server NAT'd to a public IP address? If so try connecting to it from the internal IP address when you are on your LAN. Many firewalls will block traffic that goes out the firewall from coming back in. So if the FTP server has an internal address which the firewall NAT's to the public IP address, then the ftptest.org test will work becuase it is completely outside your firewall, however, your PC may not work because it is trying to leave the network to get to a public IP address then come back in via the NAT route. Going to the Internal IP address solves this problem.

share|improve this answer
    
internal ip address works for me, but my friend who is just out side from my lan couldnt connect to it either –  srisar Mar 22 '10 at 16:38
    
also same problem happens to me when i put my apache server online with port 80, my wan address pointing to the router's home page, not my home page in the apache server! –  srisar Mar 22 '10 at 16:40
    
@srisar then there is your problem, your port forwarding is not setup in your router properly. –  Sam Mar 22 '10 at 16:54
add comment

My first guess would be you are not using passive mode like the test output does. My second would by rules on your firewall not allowing ftp in active or passive mode through.

share|improve this answer
    
also which firewall r u specifiying, because i have firewall with my AV and also on the router –  srisar Mar 22 '10 at 16:35
    
Could be either firewall (I would at least try turning off the AV one first). in the person's client, there should be a Use Passive Mode checkbox somewhere. –  Kyle Brandt Mar 22 '10 at 16:40
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.