Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I'm trying to virtualize an application for Windows 7 but am running into trouble:

Application will run fine in Windows 7 if installed in the base. When it is virtualized, it will run on XP, but not on Windows 7. I have tried this in three ways:

  1. Captured on XP with ThinApp 4.0
  2. Captured on XP with ThinApp 4.5
  3. Captured on Windows 7 with ThinApp 4.5

Even when captured on Windows 7, it will not run on Windows 7 but will run on XP.

  • When captured with a rival product, Altiris SVS, the virtualized app runs fine on Windows 7.

Any idea what could cause this behaviour?

Looking at the trace file, you see that they are different right from the start when comparing Windows 7 and XP tracefiles. What could cause it to go in completely different directions? (And why does the tracefile on Windows 7 say: Operating System Unknown? Does everybody have that on Windows 7 even with 4.5?)

The error message is: "Object variable or with block variable not set".

share|improve this question

If it virtualizes fine under Altiris (looks like Symantec bought these guys) but not under ThinApp, then why wouldn't the problem lie with ThinApp? Have you tried contacting their support?

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.