Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I am having a really hard time getting an iSeries (AS/400) machine talking to my new Windows Server 2008 R2 box using the QNTC file system on the iSeries.

I had similar problems getting it to initially talk to a Windows Server 2003 machine, but enabling the local Guest account on the 2003 box solved that one. No such luck with the new 2008 box.

When I do a WRKLNK /QNTC/SVR01 on the iSeries (which should show share listings, and does on any 2003 boxes) all I get is (Cannot find object to match specified name.).

I know the iSeries likes the same username and password on the remote server, but unfortunately for us this is not the case. Anyhow, it does currently work with different username/password combinations on a 2003 box.

To try and get the wretched things talking, I have made the 2008 server pretty open but the iSeries will not see shares on it. I have enabled the local Guest account, turned Windows firewall off, set the share permissions so Everyone has full control but to no avail.

I read something on the internet about the iSeries only being able to handle NTLM authentication (and I understand by default that Server 2008 R2 only uses NTLMv2 and has NTLM disabled), so I made a special group policy for the server and tweaked all Group Policy settings under Computer Configuration\Policies\Windows Settings\Security Settings\Local Policies\Security Options but the iSeries STILL won't see it.

Looking in my iSeries job log, I don't appear to be getting any error messages either.

We have a team of programmers who do all the system administration of the iSeries, but they are stumped for ideas on their side, and I'm stumped for ideas on my side.

This is driving me crazy now, and if anybody has managed to get an iSeries to talk to Windows Server 2008 R2 using QNTC I would be very appreciative of any suggestions, be it on the Windows side, iSeries settings or even IBM PTF's that might patch anything. The iSeries is running V5R4 and I have *SECOFR privileges on it, if it helps.

One final (most important!) note - The programmers think it's my system being tricky, and I think it's theirs - please prove me right :)

share|improve this question
add comment

4 Answers 4

up vote 2 down vote accepted

Our programmers have managed to find a solution to the problem!

The solution comes in the form of an iSeries PTF (SI38554). Note: This requires an IPL to apply the fix.

We have a tested this PTF on our test/dev machine and we can see the shares on the 2008 R2 server and also read/write to them as well.

Since we can't just IPL the live machine at will, they have come up with an ingenious solution to get us by in the mean time. What they've done is set up a share on the test machine (which has had the PTF and been IPL'ed) which basically passes through to the Server 2008 machine - i.e on the live system, doing a WRKLNK '/QNTC/QDEVSYS/SVR01' will show the share contents of the 2008 R2 server.

I hope this helps anybody else having this problem - hopefully it will save someone else a lot of time and effort.

share|improve this answer
add comment

I have been having the same problem and after some research, I have been told by our iSeries network guru that the problem is due to the fact that:

1) Microsoft has updated their CIFS protocol in Windows 2008 2) IBM has not made the necessary updates to THEIR netserver protocol to take into consideration the updates to CIFS.

Therefore, our iSeries, V5R4, will NOT be able to see the shared drives. I will therefore be moving to a windows 2003 server.

share|improve this answer
add comment

You need to turn off SMB 2.0. see how to disable smb 2 on windows vista or server 2008 at least until you get the patch that correctly negotiates SMB

share|improve this answer
add comment

This is already implemented in OS400 release 6. We had a lot of trouble figuring out how to access windows shares. Make sure you have a DOMAIN account eg. ISHARE with matching password (lowercase!). Give ISHARE permission to write on the Windows share.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.