Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I'm using ubuntu 9.10, apache 2 and mysql 5. I install ruby 1.8.7 on the server. I ran the command

gem install rails -v 1.2.3

But then I get the error

ERROR:  While executing gem ... (NoMethodError)
    undefined method `include?' for nil:NilClass

What did I do wrong?

share|improve this question

I believe you need:

gem install rails -v=1.2.3

or gem will think that 1.2.3 is a new gem to install, add the = sign.

share|improve this answer
up vote 0 down vote accepted

I formatted the disk and installed everything all over again. I was trying to replicate the settings of a very old ruby on rails server. So this time I made sure I had the correct version of all the old dependent gems. This seemed to have solved "some" of the problems.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.