Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I am working with Ubuntu latest version. While installing via apt-get install i tried to abort that by pressing Ctrl+Z. It terminate successfully ;). But next time when i tried to use apt-get, i got some error "lock" and "temporally unavailable" something like that and **I unfortunately i delete the /var/lib/dkpg folder.**

after that i cant install anything from apt-get, getting an error.

E: Internal Error, Could not perform immediate configuration (2) on libattr1

so how can i solve this issue?

share|improve this question
add comment

2 Answers

Ctrl+Z puts that process in background, so it's still executes, you should do Ctrl+C to kill it.

If you put job in background with Ctrl+Z you can get list of jobs with jobs command. And take that job in foreground with fg %n where n is number of that job as displayed by jobs.

You could try deleting /var/lib/apt/lists/lock.

share|improve this answer
add comment

Some of methods listed here may work:

http://mm.bbspals.org/linux/lost-var-lib-dpkg-on-debian/

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.