Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I have reinstalled Ubuntu 9.10 Server several times on a bog standard 1RU server and each time I finish the install and reboot I see GRUB run and am then presented with a black screen. The machine is running just fine, as I am able to SSH in, but I can't see anything on the attached monitor. I have a simple LCD screen connected via VGA and a signal is apparently being output to it, as it doesn't go asleep.

Looking at /var/log/syslog I see:

Mar 24 14:57:44 bridge5 rsyslogd-2039: Could no open output file '/dev/xconsole' [try http://www.rsyslog.com/e/2039 ]

However, I later see:

Mar 24 14:57:44 bridge5 kernel: [ 0.001368] console [tty0] enabled

Any thoughts? Thanks!

share|improve this question
2  
xconsole is unimportant; it's meant as a buffer for the xconsole utility from x11-apps, and isn't created in ubuntu. You can remove it from /etc/rsyslog.d/50-default.conf. –  Tobu Jun 29 '10 at 9:26
1  
Perhaps it is simply defaulting to the blank tty that's reserved for X11 (which provides the GUI, and which is not installed by default for Ubuntu server). What happens when you press Alt+F1? Does that enable you to log in? –  user65038 Dec 29 '10 at 23:21
    
"console [tty0] enabled" there is no tty0, the ttys start at tty1 usually. Does alt-f2 show a login prompt? Is there a line for tty1 /etc/inittab (or in /etc/init, but as it's 9.10 it probably still is inittab). –  arjarj Apr 2 '12 at 8:20
add comment

2 Answers

tty0 is usually used for a serial console. Check your config for tty0 and tty1 by looking at /etc/init/tty0.conf and /etc/init/tty1.conf respectively.

share|improve this answer
add comment

Try configuring Grub to use a specific screen resolution. See this question on superuser for further info.

share|improve this answer
    
Thanks, but unfortunately that seems to have no effect. Likewise disabling the graphical console... –  pr1001 Mar 29 '10 at 18:04
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.