Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I'm trying to learn how to work Silverstripe so I extracted the tar file to my free hosting account. I then went on install.php and edited the permissions to meet the requirements set out in install.php but I still get two warnings from the 'webserver configuration' section:

I can't tell what webserver you are running. Without Apache I can't tell if mod_rewrite is enabled.

I can't tell whether mod_rewrite is running. You may need to configure a rewriting rule yourself.

I looked in phpinfo() and mod_rewrite appears to be installed. I contacted the web host and they said it was to do with virtual directory paths, and I should add 'RewriteBase /' to the top of my .htaccess file in the public_html directory. However I did this and still had the same problem. The install.php script says that I can install it even with these warnings but when I press 'install' it just refreshes the install.php page. It doesn't even overwrite the .htaccess file. 000webhost.com says they have successfully installed Silverstripe on their user accounts without much configuration but I can't seem to find out how.

EDIT: I managed to get to the next page but now there is another warning which is stopping it installing:

Friendly URLs are not working. This is most likely because mod_rewrite isn't configuredcorrectly on your site. Please check the following things in your Apache configuration; you may need to get your web host or server administrator to do this for you:
* mod_rewrite is enabled
* AllowOverride All is set for your directory

I also get this error message from the server:

Warning: unlink(mysite/_config.php) [function.unlink]: Permission denied in /home/a2716553/public_html/install.php on line 701

share|improve this question

migrated from stackoverflow.com Mar 25 '10 at 1:12

This question came from our site for professional and enthusiast programmers.

1 Answer 1

It looks like your webserver user can't write to .htaccess and to mysite/_config.php.

Try changing the permissions of these files to 777 (rwxrwxrwx), and changing the back again after a successful installation.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.