Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

I was using phpmyadmin(in Wamp) without a password for root. I thought to set a password for root and goto Privileges page and set a password for root. Now whenever I go to localhost/phpmyadmin page it gives me the following error.

MySQL said: Documentation
#1045 - Access denied for user 'root'@'localhost' (using password: NO)
phpMyAdmin tried to connect to the MySQL server, and the server rejected 
the connection.

You should check the host, username and password in your configuration 
and make sure that they correspond to the information given by the 
administrator of the MySQL server. 

I don't know that what is the problem. It is not showing me a login type page to enter a username and password. Any idea that what is the problem ?

Thanks

share|improve this question

migrated from stackoverflow.com Mar 25 '10 at 1:12

This question came from our site for professional and enthusiast programmers.

2 Answers 2

up vote 3 down vote accepted

This is a configuration issue. To get phpMyAdmin's username / password login, you need to set the right Auth setting in your config.inc.php, probably "cookie":

auth_type = 'cookie'

prompts for a MySQL username and password in a friendly HTML form. This is also the only way by which one can log in to an arbitrary server (if $cfg['AllowArbitraryServer'] is enabled). Cookie is good for most installations (default in pma 3.1+), it provides security over config and allows multiple users to use the same phpMyAdmin installation. For IIS users, cookie is often easier to configure than http.

share|improve this answer

that's not the login/password to PHPMyAdmin, but it requires login / pwd for MySQL in config file.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.