Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I am running the site at www.euroworker.no, it's a linux server and the site has a backend editor. It's a smarty/php site, and when I try to update a few of the .tpl's (two or three) they don't update. I have tried uploading through FTP and that doesn't work either.

I have no knowledge of how servers work or anything, please help?

It runs on the livecart system.

Thanks!

share|improve this question

3 Answers 3

Most likely caused by permissions on templates_c directory not being write-able by the web server user.

Check permissions. They should be 775 on templates_c and 664 on files contained within that directory.

The group on the directory and files should be the group of the web server (most likely apache)

If this doesn't solve this problem you will need to check the log files for the error message relating to this problem. If you don't have access to your log files, contact you hosting provider for this information.

share|improve this answer
    
Hey Kyle. Any luck in getting your templates to compile. It would be useful to know what you have found out since March and if this got resolved. –  Richard Holloway Aug 13 '10 at 23:40

If you even tried ftp tpl file with no luck, maybe you put it in wrong place. I saw this in livecart docs, hope this help: http://doc.livecart.com/help/customize.templates

share|improve this answer

I used to work with Smarty and these sort of thing caused template precompiling. If precompilation is enabled, then Smarty makes files in templates_c directory. Empty this directory and try again. You don't have to worry - if Smarty won't find precompiled version of .tpl file it'll compile it again.

This feature is better for performance.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.