Server Fault is a question and answer site for system and network administrators. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

For example, foo -option 10->30 file.ext (this is an actual syntax required) redirects the output to a file named 30. How do I make cmd understand that I would like to pass the actual > character? I've tried several forms of double quotes to no avail.

share|improve this question
up vote 10 down vote accepted

The cmd escape character is ^ so:

foo -option 10-^>30 file.ext

should work for you

share|improve this answer
I never would have known/guessed that - I still can't believe that someone is writing windows software the requires a reserved character. – mfinni Mar 26 '10 at 15:12
@mfinni: I often use the caret as escape in a FOR loop containing pipe(s). Long live batch! :) – jscott Mar 26 '10 at 16:26
@jscott - lets not start that craziness :) Powershell to the rescue. – MattB Mar 26 '10 at 18:35
@mfinni: It's perfectly normal in most other places (such as Linuxland). – grawity Mar 26 '10 at 20:19
@grawity - that's why I specified "windows software". I know that when you're doing stuff in shell/batch or via pipes or other weird-ish environments, even in windows, you have to escape a lot of things. But he just said he's using cmd - I never would have thought someone would purposefully write something that guaranteed wouldn't work from cmd. – mfinni Mar 26 '10 at 21:07

You can also quote the argument:

foo -option "10->30" file.ext
share|improve this answer

Ask the vendor for the foo command how it's supposed to work?

share|improve this answer
−1. That's the shell and not the program doing something with the > here. – Joey Mar 27 '10 at 11:43
I understand that - I simply don't see a competent vendor writing software for windows with syntax that won't work out of the box on the default shell. Not sure the -1 is necessary. – mfinni Mar 27 '10 at 15:40

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.