Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

My debian 5 vps is suffering from random shutdowns. I reinstalled it several times, the hosts moved me to a different physical box, check the install image and said everyone else also uses it and is fine.

Heres the output from syslog

Mar 27 00:19:19 noobintraining-1 -- MARK --
Mar 27 00:32:01 noobintraining-1 shutdown[18142]: shutting down for system halt
Mar 27 00:32:06 noobintraining-1 init: Switching to runlevel: 0
Mar 27 00:32:06 noobintraining-1 xinetd[15907]: Exiting...
Mar 27 00:32:07 noobintraining-1 named[15865]: received control channel command 'stop -p'
Mar 27 00:32:07 noobintraining-1 named[15865]: shutting down: flushing changes
Mar 27 00:32:07 noobintraining-1 named[15865]: stopping command channel on 127.0.0.1#953
Mar 27 00:32:07 noobintraining-1 named[15865]: stopping command channel on ::1#953
Mar 27 00:32:07 noobintraining-1 named[15865]: no longer listening on ::#53
Mar 27 00:32:07 noobintraining-1 named[15865]: no longer listening on 127.0.0.1#53
Mar 27 00:32:07 noobintraining-1 named[15865]: no longer listening on 89.238.172.132#53
Mar 27 00:32:07 noobintraining-1 named[15865]: exiting
Mar 27 00:32:07 noobintraining-1 exiting on signal 15

Any help is most appreciated!

share|improve this question
    
Since it's a VPS, it's usually possible to shut down the container via some management interface. Or there may be other means to send a shutdown signal for the container. Can you eliminate that possibility? –  Chris Lercher Mar 27 '10 at 6:24
    
I did try and look at everything in the management panel but nothing stopped it / looks like it was shutting it down. –  Newbzors Mar 27 '10 at 10:13
    
Although, when I start a shutdown from the panel it shows the same stuff in syslog –  Newbzors Mar 27 '10 at 10:18
1  
So, you're already on a different physical machine, with a fresh install, that works for others? That doesn't leave many options available. Is there a slight chance, that someone else has access to the panel, or can send the shutdown signal by some means? Did you try changing passwords? Or is there some special additional software installed on your system? –  Chris Lercher Mar 27 '10 at 13:31
    
I am the only one that has access to the server but I will try changing it later and see if that changes things. I think it may be something to do with the panel though, i shalkl ask the provider. –  Newbzors Mar 27 '10 at 14:13
add comment

1 Answer

Someone could be pressing the power button performing ACPI shutdown or it just might be an issue with ACPI. The system could also have sensor problems and thus thinks it is becoming to hot and shutsdown.

Try setting acpi to off in the kernel boot options. This is most likely performed in grub(/boot/grub/menu.lst).

You should look for the section that looks like:

title           Debian GNU/Linux, kernel 2.6.26-2-amd64
root            (hd0,0)
kernel          /boot/vmlinuz-2.6.26-2-amd64 root=/dev/sda1 ro
initrd          /boot/initrd.img-2.6.26-2-amd64

Add acpi off to the kernel line like this:

   kernel          /boot/vmlinuz-2.6.26-2-amd64 root=/dev/sda1 ro acpi=off

Reboot and try out your new setting!

EDIT: if it is an ACPI issue you may find more info in the log file:

 /var/log/acpid
share|improve this answer
    
Hi, thanks for the fast response. I can't see any menu.lst file on the server or a log for acpid. The server is a VPS if that makes a difference. –  Newbzors Mar 27 '10 at 10:11
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.