Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I've installed proftpd on my debian box but I'm having having some trouble with the configuration.

In my proftpd.conf I've added;

DefaultRoot ~ !ftp_special

This works fine in that all users except members of ftp-special are unable to navigate outside of their home folder. However, I want users that are members of ftp-special to enter a special home folder when logging on to the ftp server but at the same time I want them to be able to navigate the entire server.

Right now, if a user that is a member of ftp-special logs on, his entry-point is the root ( / ).

Thanks in advance.

share|improve this question
    
I would greatly appreciate any feedback and other suggestions if what I have outlined in my question is impossible. –  John Apr 9 '10 at 16:04
    
What about changing his home in the passwd to the given directory you want them to root in removing the !ftp_special which will root them to the dir you want them to be and aswell allow them access to navigate around if they have access to it within your system. –  Prix Aug 6 '10 at 17:39
add comment

2 Answers 2

up vote 1 down vote accepted

Unfortunately I believe there is no server-side workaround for this. Users who are exempted from the "DefaultRoot" parameter are not forced by the ProFTPd daemon to be logged into a special directory. The only option that I am aware of is to ask the User to set the path on the client-side.

share|improve this answer
add comment

Currently I am aware of only solution where you should change home directories of members of group ftp-special. Maybe there is some mod for proftpd which changes current directory after login.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.