Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I'm trying to install a package from a debian repository. Trying to install manually with dpkg errors because of missing or incomplete dependencies. This got me wondering, is it a mistake to just add the debian repo to my apt sources? Thanks

Edit:

To be more specific I'm trying to install guake (the console wrapper).

Edit 2:

I'm trying to install guake 0.4.1. This resolves an issue with transparency I'm having.

share|improve this question
2  
serverfault is for questions related to server/network administration. This question seems like it is more about your desktop environment which makes it more suitable for superuser. –  Zoredache Mar 27 '10 at 21:44

4 Answers 4

up vote 8 down vote accepted

It's a bad idea to install binary packages from Debian on Ubuntu. But it's a good idea to install packages from source! So here's how:

It's not that hard. Here's how to do it (instructions taken from my old note at http://www.asheesh.org/note/backporting-with-apt-src.html ):

Step 1: Make sure you have an appropriate deb-src line

Backporting is the process of taking source packages and compiling them on your Debian(-like) system. The easiest way to find Debian "source packages" is the same way you find Debian "binary packages": apt-get and its configuration.

Make sure you have this line in /etc/apt/sources.list:

deb-src http://ftp.debian.org/debian/ unstable main

APT provides a command "apt-get source" that looks in these deb-src lines (rather than plain binary deb lines) and downloads source packages. In this tutorial, you'll use "apt-src" which is a convenient wrapper around "apt-get source".

Step 2

apt-get update

Step 3

sudo aptitude install apt-src

apt-src is a helper program that makes compiling source packages easy. It's not necessary, but it prevents you from having to type too many commands.

Step 4

 apt-src -bi install $package

If you wanted to install 'alpine', just do:

apt-src -bi install guake

The "b" stands for "build", the "i" stands for "install the resulting package", and the word "install" means "download the source for guake as found in a Debian source line from sources.list". apt-src will "install" the source into the current directory, make sure you have all the required packages to build the package (a process called "satisfying the build dependencies"), build it, and install the resulting .debs.

share|improve this answer
    
This is an awesome guide. +1 and accept if I get it to work. Quick question, I don't understand how the apt-src program knows to use the deb-src repo and not a karmic repo. Can you shed some light on that? –  TheDeeno Mar 29 '10 at 1:33
    
If you need to do this often and don't like having to go through all the steps, check this out: eyrie.org/~eagle/software/scripts/backport.html –  ptman Mar 29 '10 at 7:19
    
I updated the answer above to answer TheDeeno's question. –  paulproteus Mar 30 '10 at 20:17
    
I wouldn't call it a good idea per se -- even the build dependencies still expect an essentially Debian setup -- but it's definitely significantly less bad than installing a binary. +1 –  Shadur Sep 26 '11 at 8:45

That is probably not the best way, as Debian and Ubuntu have different system paths, library versions and other dependencies. It might work though, but it will most probably fail in some way. You could get a better answer if you specified which package you are trying to install.

Conclusion: I would not recommend you doing it, other than for experimental use.

share|improve this answer
    
added package to my question –  TheDeeno Mar 27 '10 at 20:27

Don't do that. But: guake is present in karmic: http://packages.ubuntu.com/karmic/guake, and in lucid: http://packages.ubuntu.com/hu/lucid/x11/guake You only have to enable the 'universe' repo.

share|improve this answer
    
It's in intrepid and jaunty, too: packages.ubuntu.com/intrepid/x11/guake packages.ubuntu.com/jaunty/x11/guake –  Dennis Williamson Mar 27 '10 at 21:10
    
hmm, I have guake installed 0.4.0 installed i'm trying to install 0.4.1 though. Is that in one of those repositories? Am I missing it? I updated my question to be more specific. –  TheDeeno Mar 27 '10 at 21:49

There was mention of the command:

 add-apt-repository ppa:nginx/stable

at http://railscasts.com/episodes/335-deploying-to-a-vps?view=asciicast

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.