Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

My problem is that my FTP work great, exept when i upload files on a particular client server!

on this server happen that some files are uploaded fine and others not, they stop while uploading at half of it's size, then this error is displayed:

530 Sorry, the maximum number of clients (4) from your host are already connected. Unable to make a connection. Please try again.

Obviously this is not true, i'm the only one that is uploading!

Anyone had the same experience with this!?

PS: i have tried many different FTP, all display the same error or just hung up!


share|improve this question
Did you ever get this resolved? – Chris S Jun 18 '10 at 2:59

Some FTP clients open up a connection for transfer and a control connection. That would tie up a minimum of two connections. Many FTP clients will open up multiple connections during file transfer to speed things up -- uploading 10 files through separate connections at the same time rather than uploading one at a time.

I've also seen this behavior with Windows 7 and servers using more recent versions of pure-ftpd. Connections on the server side never seem to close with Windows 7/pure-ftpd which leaves a number of them hanging until they time out.

share|improve this answer
this is exactly the kind of server in question pure-ftpd! what client i should use instead!? i have tried FileZilla, FireFTP and also some "pro" ftp's. thank's! – aSeptik Mar 28 '10 at 19:05
The issue appears to be related to Windows7 and pure-ftpd regardless of the client. Downgrading pure-ftpd to an older release, I believe 1.0.21 solved it in one case. Something in Windows7 doesn't acknowledge the TCP connection which leaves it open. At some points, the transfer stalls and times out, leaving it open on the server. Other times, the file is completely transferred, but, isn't acknowledged on Windows7 and pure-ftpd doesn't drop it. We did try proftpd, but had similar issues. Something in Windows7 doesn't like the TCP stack on some servers. – deleted Mar 28 '10 at 23:20
i'm running 3 machine, one with vista one with xp and one with nix! none of this work! anyway thank's to All. – aSeptik Mar 29 '10 at 7:57

It could be a problem with that server, or because you're using a proxy server, or because you're behind NAT.

share|improve this answer
first of, tnx for responce! i just want know why this happen only with some file!? :) and what i should do for circumvent this!? – aSeptik Mar 28 '10 at 19:03

For Linux server; Connect to root files (ex: WinSCP program)

file edit: root/etc/proftpd.conf
Update and Restart Services > Ftp Server

MaxClients 30 "Sorry, this ftp server has reached its maximum user count (%m).  Please try again later"
    <Limit LOGIN>
    <Limit WRITE>

    <Directory incoming>
      <Limit STOR>
      <Limit WRITE READ>
share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.