Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I have a service running in a box with Windows XP and a box of Server (2008). The service is configured as autmactic mode with a logon user/pwd set. The log on user is a local user. The service requires this user setting in order to run.

The issue I have right now is that the box intermittently reboot itself. I am going to investigate what is causing the reboot (hardware or application). Regardless the reason, what I need is that the service should be able to recover itself into running state after the reboot. I think the configuration should be able achieve this goal since the user/pwd having been set and its mode being automatic. Do I need to log in as that user to bring the service back? (sometimes the reboot happens in the midnight)

I am not sure if there is any difference between Windows XP and Windows Server (2008). The only thing I realize is that when there is a unexpected reboot, the Windows Server will prompt a dialog to explain the previous reboot. Will this prevent any automatic service running or the service will run only the reason has been set?

share|improve this question
    
I have restated my question –  David.Chu.ca Mar 29 '10 at 16:34

1 Answer 1

up vote 1 down vote accepted

so say you have user "AAA" are you having user AAA login to the desktop at the same time you have a service set to start as AAA? If so why, just create another account for the service to run under that has the right priv's.

share|improve this answer
    
That's right. "AAA" as local user and for the service to run. The issue is that when an unexpected reboot happens, the service is down. I have to log in as "AAA" afterwords to restart the service. However, the service has been down for a while. What I need is to restart the service every time for a reboot (even no one logging yet). –  David.Chu.ca Mar 29 '10 at 15:56
    
once again why do they have to be the same account? Just have AAA running with the same permissions that the logged in user has but not the same name. –  tony roth Mar 29 '10 at 16:32
    
also when you say "running in a box" do you mean an interactive service? –  tony roth Mar 29 '10 at 16:34
    
It is a windows service, the service in services.msc console. –  David.Chu.ca Mar 29 '10 at 16:35
    
if you have a service that set to login as "AAA" and its valid and has the right to "log in as service" then the service should start fine after a reboot. If it doesn't then things like interaction with the desktop could cause the service to not start. Look in to the system log you should see the error there! –  tony roth Mar 29 '10 at 17:06

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.