Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

I can access https://svnserver:80/ locally via my web browser, but when I remove the :80 it doesn't work at all.... any ideas?

UPDATE

When I go to https://svnserver:443/ it says:

SSL received a record that exceeded the maximum permissible length.

(Error code: ssl_error_rx_record_too_long)

I followed the default instructions for creating a private ssh key on Ubuntu via the official docs...

UPDATE

My ports.conf

NameVirtualHost *:80
Listen 80

<IfModule mod_ssl.c>
    # SSL name based virtual hosts are not yet supported, therefore no
    # NameVirtualHost statement here
    Listen 443
</IfModule>

netstat -lp results

Active Internet connections (only servers)
Proto Recv-Q Send-Q Local Address           Foreign Address         State       PID/Program name
tcp        0      0 *:www                   *:*                     LISTEN      5285/apache2    
tcp        0      0 *:https                 *:*                     LISTEN      5285/apache2    
tcp        0      0 *:22                    *:*                     LISTEN      2351/sshd       
tcp6       0      0 [::]:22                 [::]:*                  LISTEN      2351/sshd       
udp        0      0 *:bootpc                *:*                                 2239/dhclient3  
Active UNIX domain sockets (only servers)
Proto RefCnt Flags       Type       State         I-Node   PID/Program name    Path
unix  2      [ ACC ]     STREAM     LISTENING     14927    5288/apache2        /var/run/apache2/cgisock.5285
unix  2      [ ACC ]     STREAM     LISTENING     5032     2114/dbus-daemon    /var/run/dbus/system_bus_socket
unix  2      [ ACC ]     STREAM     LISTENING     4857     2039/acpid          /var/run/acpid.socket
share|improve this question
    
Can you post the output from netstat -lp so we can see that the right software is bound to those ports? –  pehrs Mar 29 '10 at 19:00
    
Done, though I'm not sure what I'm looking for –  Webnet Mar 29 '10 at 19:44
    
The netstat command confirms that apache is listening on on 80 and 443 BUT it makes it also makes an assumption that 80 is www and 443 is https. And while your ports.conf looks correct, the browser gymnastics your doing suggests that there's more going on here. This seems like a good excuse for me to learn more about subversion... –  Bob Apr 1 '10 at 19:22

3 Answers 3

For some reason this svn server has https configured on port 80. The browser needs to be told that it's looking for an https server on port 80/TCP, that's why you need to specify both https and :80.

Background:

Standard web traffic goes over port 80/TCP Standard https traffic goes over port 443/TCP

Most web browsers assume that unqualified URLs are standard http connections and send them to port 80. Web servers that require https will often do a redirect (like a 403) to send the browser to the HTTPS version of the page, however the web browser also assumes that HTTPS traffic happens on 443/TCP. HTTPS traffic on non-standard ports must be specified in the URL otherwise the browser will try to send it to 443/TCP.

To reiterate, if there's no HTTP page redirecting your browser to the proper HTTPS content and the HTTPS content is on a non-standard port you'll always need to specify both the protocol and the port.

Update

I looked over at this question: Setting up https with a self-signed certificate on Apache

And the answers may address your configuration issue. It sounds like the HTTP may be listening on 443 and the HTTPS on 80

share|improve this answer
    
I've added my ports.conf which shows that they are listening to the correct ports. –  Webnet Mar 29 '10 at 18:56

That's b/c https is port 443 and port 80 is http. I would use wireshark to see if it is indeed using https or http when forcing traffic to port 80.

Beyond that it's a matter of getting your Apache/IIS configuration setup correctly.

share|improve this answer
up vote 0 down vote accepted

I've realized now that the reason I can do this is because my local linux machine that I'm browsing the site on has record of svnserver since I have ssh'd to it before. :doh:!

SSL is also throwing an error when I change :80 to :443 meaning that 80 is not encrypting the data even though it's showing https and throwing no errors.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.