Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I'm trying to connect to a server but if i use any other user than root the connection closes itself after a successful login:

XXXXXXX:~ user$ ssh -v XXXXXXX@XXXXXXX.XXXXXX.XXX
OpenSSH_5.2p1, OpenSSL 0.9.8l 5 Nov 2009
debug1: Reading configuration data /etc/ssh_config
debug1: Connecting to XXXXXXX.XXXXXX.XXX [xxx.xxx.xxx.xxx] port 22.
debug1: Connection established.
debug1: identity file /Users/user/.ssh/identity type -1
debug1: identity file /Users/user/.ssh/id_rsa type -1
debug1: identity file /Users/user/.ssh/id_dsa type 2
debug1: Remote protocol version 2.0, remote software version OpenSSH_4.3
debug1: match: OpenSSH_4.3 pat OpenSSH_4*
debug1: Enabling compatibility mode for protocol 2.0
debug1: Local version string SSH-2.0-OpenSSH_5.2
debug1: SSH2_MSG_KEXINIT sent
debug1: SSH2_MSG_KEXINIT received
debug1: kex: server->client aes128-ctr hmac-md5 none
debug1: kex: client->server aes128-ctr hmac-md5 none
debug1: SSH2_MSG_KEX_DH_GEX_REQUEST(1024<1024<8192) sent
debug1: expecting SSH2_MSG_KEX_DH_GEX_GROUP
debug1: SSH2_MSG_KEX_DH_GEX_INIT sent
debug1: expecting SSH2_MSG_KEX_DH_GEX_REPLY
debug1: Host 'XXXXXXX.XXXXXX.XXX' is known and matches the RSA host key.
debug1: Found key in /Users/user/.ssh/known_hosts:12
debug1: ssh_rsa_verify: signature correct
debug1: SSH2_MSG_NEWKEYS sent
debug1: expecting SSH2_MSG_NEWKEYS
debug1: SSH2_MSG_NEWKEYS received
debug1: SSH2_MSG_SERVICE_REQUEST sent
debug1: SSH2_MSG_SERVICE_ACCEPT received
debug1: Authentications that can continue: publickey,gssapi-with-mic,password
debug1: Next authentication method: publickey
debug1: Offering public key: /Users/user/.ssh/woo_openssh
debug1: Authentications that can continue: publickey,gssapi-with-mic,password
debug1: Offering public key: /Users/user/.ssh/sidlee.dsa
debug1: Authentications that can continue: publickey,gssapi-with-mic,password
debug1: Trying private key: /Users/user/.ssh/identity
debug1: Trying private key: /Users/user/.ssh/id_rsa
debug1: Offering public key: /Users/user/.ssh/id_dsa
debug1: Authentications that can continue: publickey,gssapi-with-mic,password
debug1: Next authentication method: password
XXXXXXX@XXXXXXX.XXXXXX.XXX's password: 
debug1: Authentication succeeded (password).
debug1: channel 0: new [client-session]
debug1: Entering interactive session.
Last login: Mon Mar 29 01:41:51 2010 from 193.67.179.2
debug1: client_input_channel_req: channel 0 rtype exit-status reply 0
debug1: channel 0: free: client-session, nchannels 1
Connection to XXXXXXX.XXXXXX.XXX closed.
Transferred: sent 2976, received 2136 bytes, in 0.5 seconds
Bytes per second: sent 5892.2, received 4229.1
debug1: Exit status 1

If i log in as root the exact same way it works as expected.

I've added the users i want to log in with to a group (sshusers) and added that group to /etc/sshd_config:

AllowGroups sshusers

I'm not sure what to try next as i don't get a clear error anywhere. I would like to enable specific accounts to log in so that i can disable root.

This is a GridServer/Media Temple (CentOS).

share|improve this question
add comment

1 Answer

up vote 1 down vote accepted

It looks like it is failing around the PAM step. Can you check the output of /var/log/secure, /var/log/messages /var/log/authlog? Verify the user has a valid shell and there is no PAM reason why they wouldn't be able to login.

Can the user login from the console? Are you able to "su -" to the account?

Try altering UsePAM to "no" to see whether this is your problem.

Is the user local to the machine or in LDAP/NIS ?

share|improve this answer
    
I disabled PAM (this was the first issue) but also noticed that the user didn't have a valid shell. I changed this in /etc/passwd and now login works. Thanks! –  Antti Mar 30 '10 at 10:48
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.