Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

I need my LPT1 port to be available in XP mode.

In the "guest" window, it shows up in system hardware, but it is not available to the application.

If I look into Tools, settings there are no parallel port available?

How can I fix this problem? (If I use VMWare Workstation XP mode, I load a driver and it works perfect).

share|improve this question

1 Answer 1

if you have hooked your printer via LPT1 and you are able to print from Windows 7, try this: in XP mode go to Printers, Add new printer, uncheck Plug'n Play, continue and select your printer from list. If there are not the same printer, try "have Disc" but it is not successful in more cases. So check Windows Update button left side from Have disc and with luck you can obtain similar or the same printer to list. Check it and install (be patience...). After it try to print (Properties, Test page). If you are not successful, see what other ports are available in Port list in Printer Properties. There are some ports as TS001, TS002 etc...with name "Inactive" or name your host computer. So check field "Enable printers resources" on the bottom and check field of the port with the lowest number, e.g. TS001 but this port must have name of your host computer. After it you can see that there are two identical printers, one on LPT1 and second on port TS....Save and try to print again and enjoy (maybe). If it will be failed, try another port from host computer. I tested it with old 16bit application (FoxPro) and I am able to print there. Bye, Vratislav (sorry for my English :-)))

share|improve this answer
    
But if you need to print to winprinter (that needs bidirectional support, maybe even ECP) then you will not succeed. I am wondering how I can get this to work. Some winprinters need bidirectional support (ECP). For that the emulated paprallel port should be able to get interrupts, DMA and specific address ranges. –  user48122 Apr 24 '11 at 3:48

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.