Server Fault is a question and answer site for system and network administrators. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

i have a issue related to dhcp i have configured my dhcp according to my ip and all ...

but it fails. when i try to start the service...

i tried to trouble shoot and i stopped the firewall (iptables) i disabled selinux.

is there any other area i need to consider.. is there anything that stops dhcpd service to start from.

share|improve this question

migrated from Mar 30 '10 at 14:50

This question came from our site for professional and enthusiast programmers.

"failed to start" is too little information. Look at your error logs. But better still post this over at – Steve Kemp Mar 30 '10 at 14:17
Don't you want to provide us a little more information? Or if you solved the problem, just tell us what was wrong? – Vladislav Rastrusny Apr 16 '10 at 11:31
up vote 1 down vote accepted

check /var/log/messages when starting dhcp (with tail -f /var/log/messages) you'll see why it's failing. most likely it's going to be something obvious, but if you can't work it out, post the error message in your question, so everyone can see what's happening. you may also want to give the network configuration (/sbin/ip add), usual dhcp problems are related to wrong subnet definition etc.

also, try running dhcpd -t to test your config files.

share|improve this answer

protected by Community Dec 12 '14 at 14:21

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.