Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I have a single Exchange 2003 installation which for the past 2 years has been set up for Outlook Anywhere access by means of a self-signed certificate. Just this past week I updated that certificate to a Go Daddy wildcard certificate to allow for use of our web services over https. I've updated the web listener on our ISA 2006 firewall and I can successfully use our services over https. However, my Outlook Anywhere access is now not functioning. I've installed the new wildcard certificate on my XP notebook into the Trusted Root Certificate Store but I keep getting prompted that the password is incorrect.

To make things even more confusing I also have OWA set up and this works fine with the new certificate. Any ideas as to what I'm doing wrong?

share|improve this question

1 Answer 1

up vote 0 down vote accepted

Figured it out and am answering the question to help others that may be making the same changes. When migrating from a regular certificate to a wildcard certificate you must change the MSSTD (principal name in Microsoft-Standard Form) in the MS Exchange Proxy Settings and ensure that IF you have a principal name set you'll need to change it. In my example since I was migrating from a regular cert to a wildcard I had to change it from:

msstd:webmail.domain.com to msstd:*.domain.com

After that change everything worked like a charm!

Edit: This is a setting done on outlook clients prior to 2010. You find it under Connection -> Proxy Settings of the users mailbox

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.