Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

I have installed Google Sitemap Generator on my CentOS server, which is running plesk 8.6.

Google Sitemap Generator adds an include to an external conf in my httpd.conf as follows:

Listen 8181
NameVirtualHost *:8181
<VirtualHost *:8181>
DocumentRoot "/usr/local/google-sitemap-generator/admin-console"
ScriptAlias /cgi-bin/ "/usr/local/google-sitemap-generator/admin-console/cgi-bin/"

 <Directory "/usr/local/google-sitemap-generator/admin-console">
    Allow from all
    Options ExecCGI
    DirectoryIndex index.html
  </Directory>
</VirtualHost>

LoadModule google_sitemap_generator_module /usr/local/google-sitemap-generator/lib/mod_sitemap.so

After installation I should be able to navigate to myserverip:8181 and access the GSG console. Unfortunately my browser throws up "Safari can’t open the page “http://myserverip:8181/” because the server where this page is located isn’t responding."

I've checked the port with netstat and nmap, and it's open and listening. I've added a rule to allow traffic on 8181 in iptables, but no joy.

Is there anything obvious I could be missing?

Any ideas would be greatly appreciated.

Cheers,

Ian

share|improve this question

3 Answers 3

Does everything look OK in the error log? If not, follow the steps below.

First, check locally on the server:

$ nc localhost 8181

Then check using your external IP, but still from the server:

$ nc myserverip 8181

If that all worked (and it should have), check from your remote computer:

nc myserverip 8181

Does that work? If not, there might be a firewall somewhere between your computer and your server disallowing access to that port. It might be your ISP blockin outgoing connections to 8181, or your hosting provider blocking incoming connection to that (or all non-standard) port(s).

If you were able to connect, send some HTTP requests, either using netcat (or telnet) again, or a tool like wget, curl, GET, HEAD (not head), ... If you get a 500 error, check Apache's error log.

share|improve this answer
    
Thanks for the help! I tried netcat, and it just hangs (unable to connect). If I try it on a port that I know works - i.e. SSH, it connects and gives the appropriate response. Does this mean a more fundamental error with my configuration somewhere? –  soopadoubled Mar 31 '10 at 9:52
    
I meant to say - I don't see any references to this problem in the error log. –  soopadoubled Mar 31 '10 at 9:57
    
Thanks for this nc command, helped me figure out something totally unrelated! –  Tom Oct 4 '10 at 15:46
up vote 1 down vote accepted

Thanks for everyones input.

It turns out that my VPS provider operates a firewall on the VPS containers.

By some massive fluke, any previous services I had configured (including SSH) I had set on some of the few ports open on their firewall.

I had never considered another firewall to be the issue, having successfully used (by sheer luck) 'random' ports in the past.

Thanks again for your time,

Ian

share|improve this answer
    
So, in fact, my answer was correct? :-) "your hosting provider blocking incoming connection[s] to that (or all non-standard) port(s)." –  janmoesen Apr 1 '10 at 9:49

Sorry for obvious question but did you restart/reload Apache? On the command line of the server is apache listening on the port? ( netstat -tupan | grep 8181 )

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.