Server Fault is a question and answer site for system and network administrators. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

It's strange. I can upload a document named 47k.txt that is 47,297 bytes using the "Multiple Document Upload" feature. If I do any of the following to the file, the upload fails:

  • Add a single character to the end of the text file
  • Add a character to the file name (e.g. 47kx.txt)
  • Put the file in a subfolder (thereby increasing the total length of the file path)

This is the error I get in the SharePoint logs:

Category: General                        
Event ID: 8jzm 
Level: High     
Message: #90012: An error was encountered while processing files on the server. 
         Try uploading one file at a time by using the single upload page.

The same error is reported in a message box on the client side.

Does anybody know why this would happen?

EDIT: This breaks when uploading a single file over 47,297 bytes, or multiple files whose file sizes together are greater than about 47k. So, I could successfully upload 20 files that are all 1k, but the upload fails if I tried to upload a 10k file and a 40k file at the same time.

share|improve this question
@Jim - are you uploading the file by itself, or with other files at the same time? – MattB Mar 30 '10 at 19:28
@MattB - It can break both ways. I'll add more description to the question. – Jim Mar 31 '10 at 20:19
I suppose this is a dumb question, but you can upload the larger documents individually (using the single document upload interface) – MattB Mar 31 '10 at 20:34
Maybe someone has edited the "AspMaxRequestEntityAllowed" in the metabase? – vinny Mar 31 '10 at 23:02
"The data in a POST request is truncated to 49,152 bytes when an ASP.NET-connected application receives the POST request" - I'm not sure why this would apply to only some of our servers, but it seems to be what we're experiencing. – Jim Apr 1 '10 at 14:44

This is a known issue with .NET 2.0. The problem is listed in the fixes included with .NET 2.0 sp1. So, it looks like we really just need to update our service packs and the problem will be fixed. Since SharePoint is built on ASP.NET, any bugs in the .NET framework will be present in SharePoint.

share|improve this answer

47,297 is a prime number? See if it'll do 47293 or 47303.

(I really have no idea. 47k bytes is trivial for that program.)

share|improve this answer
Interesting idea. Anything bigger than 47,297 breaks, though (if the file name and path remain the same). So I don't think it's a prime # issue. – Jim Mar 31 '10 at 20:22

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.