Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I setuped gitosis on a linux server following this tutorial:

http://scie.nti.st/2007/11/14/hosting-git-repositories-the-easy-and-secure-way

We are using git on our windows machines with TortoiseGit and msysgit.

Pushing changes to the server is pretty fast, but when we want to clone or fetch changes from the remote server, it begins really fast (800k/s) and then drop pretty fast to around 3 to 30k/s and it can take forever to update. git-pull for small update is fast, but as soon as we have to download something of more than a few MB, it is slow.

We are switching from SVN to git and this is holding us back from using git full time.

Thanks!

share|improve this question
    
The fact that it starts fast, then slows way down would make me wonder if there is some traffic-limiting device involved. Are you running over ssh or git: or http: ? - Greg –  Gregor Apr 1 '10 at 21:25
    
We found out after some testing that SSH was the problem with msysgit. When we used scp to transfer a file to our server with msysgit, the transfer started fast and then slowed down. We tested from a Mac computer, did the same command and it was fast. So there's something wrong with OpenSSH in the msysgit distribution. –  EtienneT Apr 6 '10 at 13:13
    
May be some kind of traffic shaping somewhere? Is the speed stable after slowdown? –  Vi. Apr 7 '10 at 2:14
    
Are You under a vpn connection ? –  aleroot Sep 4 '11 at 19:53
    
You may want to check out gitolite. Gitosis hasn't been updated for a while. Also gitolite is very easy to setup :) –  Dean Perry Sep 4 '11 at 20:01

2 Answers 2

Looks like you solved the issue but thought I would add my experience. When we tried to implement git we discovered that clones were much slower when done on a NFS mount so we now advise everyone to use local disks.

share|improve this answer

Like you were able to identify, this is a client issue, not the server fault.

If you want, you can configure TortoiseGit to use Putty's plink instead of its custom implementation.

Then you can customize the default settings using Putty.

In Putty "Default Settings", enable the following:

  1. SSH -> Auth: "Allow agent forwarding" (I believe this is the one that changes "everything")
  2. SSH -> "Enable Compression"
  3. Session -> Select "Default Settings" -> Save

For me, this resulted in going from 143.00 KiB/s to 4.50 MiB/s

Hope this helps.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.