Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

Some programs are about to make me epileptic with excessive screen flashing/blinking (terminator etc.). In Ubuntu Hardy Heron I could solve the problem by unchecking System->Preferences->Sound->System Beep->Visual system beep. However on Karmic Koala there is no such option. I googled and found many solutions for turning off visual beep/bell. However nothing seems to work. So my question is that what is the exact alternative to disable Visual system beep on Karmic?

share|improve this question
add comment

3 Answers

up vote 0 down vote accepted

Maybe the problem is the module pcspkr

check if the module is loaded

 lsmod | grep pcspkr

if its loaded you can unload it with

 sudo rmmod pcspkr

if the annoying beeps disappear you have to blacklist the module: Add the line

 blacklist pcspkr

to the file /etc/modprobe.d/blacklist.conf if it exists. I do not know how ubuntu 9.04 or 9.10 do store the blacklisted modules.

share|improve this answer
    
ha I didn't read your last entry ;-) in Ubuntu 10.4 the pcspkr mod is blacklisted per default and in my case it's not even installed –  grub Jun 14 '10 at 19:51
    
Thanks, I thought I had pcspkr disabled already, but probably wasn't. Also you pointed out pcsprk being blacklisted in the latest ubuntu. –  user19725 Jun 16 '10 at 5:27
add comment

Try running:

gconf-editor &

and navigate to:

/apps/compiz/plugins/fade/screen0/options/visual_bell
/apps/compiz/plugins/fade/screen0/options/fullscreen_visual_bell
/apps/metacity/general/visual_bell_type
/apps/metacity/general/visual_bell

and see how they're set.

Also, some apps (e.g. screen) have their own controls for the visual bell.

share|improve this answer
    
Those are not set. So unfortunately no clue here :(. So far my only hope is to run older Ubuntu versions. –  user19725 Apr 7 '10 at 6:29
add comment

It might be that my question was obsolete. I could repeat the problem with 9.04 and 9.10. With 8.04 and 10.04 there is no problem.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.