Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

I am having some trouble getting into phpmyadmin when trying to login. The only error that comes up is "Cookies must be enabled past this point"

I have checked my browser setting to allow cookies. Our server is running on Ubuntu.

Would anyone have any suggestion onto where to begin looking for solution to this problem.

share|improve this question
    
How about you try a different web browser? –  Jimmy Apr 1 '10 at 11:00

5 Answers 5

In the phpmyadmin directory, edit the config.inc.php and set a custom blowfish_secret, a good random secret can be generated via the WordPress API salt page, just use one of the constant values.

/* YOU MUST FILL IN THIS FOR COOKIE AUTH! */
$cfg['blowfish_secret'] = 'Your blowfish secret here'; 

HTH

share|improve this answer

That message is displayed if you are using cookie based authentication before you are authenticated and does not mean your credentials are incorrect.

My suggestion of where to start looking is to check your log in credentials are correct by connecting to MySQL with the MySQL client.

mysql -u <username> -p

and enter the password when prompted.

If you have the correct username and password, then you could try changing the authentication method used by phpMyAdmin to http authentication which will allow you to log in without using cookies.

share|improve this answer
    
Hi Richard, I will this a go and let you know how i went. Thanks for the reply. –  freddy6 Apr 7 '10 at 3:33
    
Hey freddy6, any luck with this yet? –  Richard Holloway Apr 12 '10 at 21:25
    
Hi Richard, i can log into the mysql database fine from command line, I am just trying to find out how to change the authentication method to http authentication. –  freddy6 Apr 14 '10 at 0:53
    
In a file called config.inc.php . You are looking to change the line to look lke this: $cfg['Servers'][$i]['auth_type'] = 'http'; –  Richard Holloway Apr 15 '10 at 11:32
    
freddy6, did you ever get this working? –  Richard Holloway Aug 13 '10 at 23:38

go to mozilla forefox tools->Options->privacy and then check the option accept cookies from sites and then retry to login into phpmyadmin.

share|improve this answer

I had this same issue. It turns out that virtual machine I was running on was out of disk space. Use the command df -h to determine your disk space and clear up some space.

share|improve this answer

Check if you've blocked cookies for localhost (or the domain where phpMyAdmin is). This is similar to @diEcho's answer, but FF makes it hard to figure out where the cookies are blocked and I like dummie's guides...

Googling for this brings up a solution in a forum post:

And... In Firefox, for some unknown reason, local host and 127.0.0.1 were both blocked. Removed this block, and everything OK in Firefox. Had more difficulty clearing the blocks in IE, but in the end managed to get this working.

For Mozilla Firefox (v33):

  1. Go to Tools > Options > Privacy (tab)
  2. Select Firefox will: 'Use custom settings for history'
  3. Make sure Accept cookies from sites is checked on
  4. Click Exceptions... and look for localhost, make sure that either nothing is there or the Status is not 'Block' - if it is blocked then click on the row and click 'Remove Site'
  5. Retry to login into phpmyadmin

Privacy options dialog

Cookie Exceptions dialog

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.