Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

Last night I upgraded a server (Dell 2970) to have four 1TB Hard Drives in RAID 5 which leaves a 3TB block. I tried to partition this but keep getting an error that GPT is not supported so.

I found a site online telling me I need to run the dd command and right random data to /dev/sda. This is great (if it works) but taking forever. I have two more machines to upgrade today and not a chair in sight! Does anyone have advice on how I can avoid this issue beforehand?

Thank You for your advice and support.

share|improve this question
    
You should have gotten a proper server. Seriously. One that supports light's out - by having a remote desktop solution integrated. I was upgrading the BIOS on my servers two months ago and installing operating systems - NOT being at the colocation facility. Check what Dell offers in this area and get your servers upgraded. –  TomTom Apr 1 '10 at 14:36
    
You probably mean the DRAC cards. The 2970 should work with DRAC5. –  dyasny Apr 1 '10 at 14:38
    
@TomTom - DRACs are common add-ons to Dell servers. It certainly is a "proper server," it just seems that the OP left that option off. –  MDMarra Sep 2 '10 at 15:43
1  
11 questions, 0 answers and a 33% acceptance rate. You suck at Server Fault. –  Coops Mar 2 '11 at 23:08

2 Answers 2

up vote 2 down vote accepted

Do you really need such a large partition? I would split it up into smaller chunks using LVM on top of the RAID array, to avoid using unsupported workarounds.

share|improve this answer
    
To the guys who mention the DRAC card, I do have a DRAC card but need to be here so I can upgrade three more systems after this machine is done. But thank you anyhow. The RAID array was created in the Dell Utility. Should I great a software RAID array in the CentOS installer and put LVM on top of that? I don't have much skills in manually partitioning my drives what I have right now is /dev/sda1 is 2 gigs for /boot /dev/sda2 VolGroup00 is 700 Gigs and than the rest is free space. Still getting same error about GPT. –  sxanness Apr 1 '10 at 16:38
    
If you have a PERC5/i or PERC6/i in there, you better leave the array configured there, and build the LVM on top of that (should show up as a really large /dev/sda) You can create another VG on the free space, or use the free space as a new PV for another LV in VolGroup00 - that's up to you –  dyasny Apr 1 '10 at 19:03
    
Thank you, this is what I did and it worked. Thank you for your help. –  sxanness Apr 1 '10 at 19:20
    
Glad I could help :) –  dyasny Apr 1 '10 at 20:41

You can install CentOS onto GPT disk layouts using a combination of SystemRescueCD, CentOS 5.0 and a patched version of grub.

Although it does involve unsupported work-arounds this is only for the installation itself. The result is a standard CentOS server.

It is quite a lengthy process but can be achieved and I have written up this how to Install CentOS onto large partitions using gpt disk layout on my blog.

share|improve this answer
    
Richard, your link is broken, would you try to fix it please? Thanks. –  Chopper3 Jan 24 '11 at 15:10
    
Chopper3: Sorry about that. I have set up a new blog and edited the link so it should work again. –  Richard Holloway Mar 2 '11 at 23:04
    
I get a lot of people click through to my site from this link but the answer here has only one upvote and my post has no comments. I want to make sure that my post helps people get around the limitations of CentOS5 installation. If it doesn't, can you let me know so I can add more detail? –  Richard Holloway Feb 15 '12 at 22:58
    
If your drives are 2Tb or less it's much easier to just use SystemRescueCD to convert the GPT partition tables on the drives to MSDOS (if you are stuck using CentOS 5 for compatibility reasons). I did this last night to solve the SolusVM Xen problem. –  linux911 Feb 3 '13 at 13:14
    
If you have <2TB drives, yes you don't need to mess about with GPT and can use MSDOS. –  Richard Holloway Feb 5 '13 at 11:52

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.