Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I have a question regarding packages repository in Debian (Lenny). A new server at rackspace cloud service comes with nothing (plain system) so i had to upgrade system and install all necessary packages by myself. But the problem is that default repositories does not provide newer versions of software i need (PHP is 5.2.6, comparing to 5.2.13). In CentOS i used to get all new packages from third-party sources, which works really well till now. I have talked to guys from rackspace about it and looks like they cant provide anything except kernel headers. And i dont really want to build from source.

So, whats the way to get newer software ? Any good third party sources?

Thanks.

share|improve this question

5 Answers 5

up vote 3 down vote accepted

If you are only looking for packages such as PHP to be updated, you might try the repositories at http://www.dotdeb.org/. I have used these packages before with good results on a Debian webserver.

share|improve this answer

You should use http://backports.org for newer versions.

share|improve this answer

In CentOS/RHEL, I can see the motivation to hunt down third parties. But Debian, as a group of people, is open enough that by and large people don't start third party repositories. Granted, Debian stable is renowned for being out of date. This is partially due to having so many packages available. In fact, one of the founding principles of Ubuntu was time based releases, which basically says no one bug fix is worth holding up the rest of the fixes and features.

What you might do is see if anyone hosts a local Debian mirror to save on bandwidth costs. And consider upgrading to Debian testing (unstable is not advisable for the inexperienced). Testing (codename Squeeze) has PHP 5.3.0. If you need 5.2.x, you'll have to dig into the archives I guess. Or upgrade the dependencies. Or switch to Ubuntu 9.10, which has PHP 5.2.10+security patches for another year.

share|improve this answer

What you can do is replace your /etc/apt/sources.list with

deb http://ftp.us.debian.org/debian testing main contrib non-free

then, do an apt-get update and apt-get dist-upgrade which would get you into squeeze which is going to be much closer and is stable. We've run testing on production servers for quite some time and it is reasonably close to release versions.

share|improve this answer

http://mirror.debian.org/status.html

Choose the closest to your server.

Some of them should be preconfigured.

There also may be special repositories for specific programs/group of programs.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.