Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I have Exchange 2003 servers and two Windows 2003 domain controllers. None of the Exchange servers are domain controllers. Both domain controllers are in the same 'site' and have global catalog checked in the NTDS settings. When I disconnected the main domain controller Exchange email stopped flowing.

Right now I don't have any event log errors, but might add them after I try this again. Is anyone aware of something else that might need to be done for this to work?

share|improve this question

4 Answers 4

The DSAccess component of Exchange 2003 does topology discovery every 15 minutes. The discovery process has seven steps, described in the Microsoft documentation. The behavior you're seeing is not uncommon; when the GC Exchange is using goes away, it may take up to 15 minutes for it to kick off a topology rediscovery and try again. The suggestion of restarting the SA will fix the problem, but it may also interrupt users who are currently connected, so beware.

share|improve this answer
    
So if it has the secondary GC server is already in the Directory access (That neobyte describes), will it still take up to 15 minutes to switch? –  Kyle Brandt May 27 '09 at 15:20
    
Yes, that's correct. –  Paul Robichaux May 27 '09 at 15:55

As I understand it, when Exchange starts it associates itself with a particular Global Catalog. It must be currently using your main domain controller.

After disconnecting your main domain controller, restart the Exchange system attendant service and mail functionality should return. Alternatively you could restart Exchange itself.

Update: From within the Exchange System Manager, drill down into your Admin Groups, find your server, right click on it and choose properties. Under Directory Access it should list the GCs it has detected automatically. I'm not sure exactly how it detects them, but I assume you should be able to add in alternative ones there manually if you want.

share|improve this answer
    
There really isn't any sort of automated failover ... ? –  Kyle Brandt May 27 '09 at 14:23
    
Hold on I'll update with a bit more.. –  Neobyte May 27 '09 at 14:35

This is a bit obscure, but I ran into it with an exchange server I inherited. For whatever reason, someone had set one of the the internal DNS servers as the external DNS server within System Manager, overriding OS DNS settings.

It's buried under: administrative groups, [group], servers, [server], protocols, SMTP, default SMTP virtual server properties, delivery, advanced, configure.

share|improve this answer

It is most likely a DNS issue. Make sure that DNS is installed on both your DC's (or a separate server), and ensure that the Exchange server only has the IP's of these internal DNS servers.

When testing take a look at your mail queues and see what errors are showing when you click on undeliverable queues.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.