Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

I am using gmail as my email provider for a domain name that I control. I want to send email from my dedicated server that is being hosted by a real hosting company and I don't like the 500 message per day cap. To address this issue I would like to run postfix to only send email, i would prefer if incoming port 25 blocked by my firewall. I can send email, however google marks all messages sent with postfix as SPAM. How do I make sure that people know email sent with postfix is valid?

share|improve this question

6 Answers 6

up vote 3 down vote accepted
+100

Before you put any time at all into Postfix go here and check the public IP address that you're using.

http://www.dnsblcheck.co.uk

If you're on a residential DSL block you may be screwed regardless of anything you do.

share|improve this answer
    
+1 my server's IP is on this list... Butm I don't understand why people think i'm trying to send email from my house. This is a dedicated server. –  Rook May 3 '10 at 18:52
    
Which lists are you on? Different DNSBL's have different listing criteria and (don't take this the wrong way I'm just telling it how it is) the people running them are free to choose their criteria and the people who use them are free to use them, or not use them if the impact on legitimate mail is too high. I'd suspect that your hosting provider has been listed, given they're a hosting company it's most likely because of an excess of spam in the past, really it does depend on the specific DNSBL. –  Hutch May 3 '10 at 19:39
    
@The Rook, it doesn't matter if it's a dedicated server or a toaster; it's connected via a residential class connection. That's going to be a problem. –  Chris S May 4 '10 at 12:59
    
@Chris S I have said absolutely nothing about a residential internet connection, I think you are tripping. This is a dedicated server at a real hosting company. –  Rook May 4 '10 at 18:31
    
@The Rook, my apologies, must have read that too quick. Your server's IP is still blacklisted, which is still the source of the problem. –  Chris S May 4 '10 at 19:12

I am using gmail as my email provider.

Ok, so I'm working under the assumption that you have an address, let's call it myaddress@gmail.com that you're sending from, and you're receiving email at google using that address.

I want to send email from my dedicated server and I don't like the 500 message per day cap.

Ok, you want to switch to a server you control because there is a limit to the number of messages in a day. Got it.

To address this issue I would like to run postfix to only send email, i would prefer if incoming port 25 blocked by my firewall.

Right here is the first problem. Blocking all inbound traffic without regard to the reason for the traffic arriving at that port will create problems all the way around. SMTP is a bidirection communication protocol and you'll just confuse the bejeebers out of whatever SMTP server you're sending to upstream.

The short of that is, unblock port 25.

I can send email, however google marks all messages sent with postfix as SPAM.

Ok, at this point, you'll need to provide some headers for examination, or some logs. Your mail could be blocked for a variety of reasons and without knowing how you have it set up, any guesses I would make would be shots in the dark.

I will say that Google would have to be insane to allow any SMTP server to send an email into itself that didn't originate from their domain but claims to be coming from it; it could be as simple as the fact that your SMTP server is not "authorized" on their servers to handle mail for Google's domain. This is a common anti-relay setting for most SMTP servers and would certainly explain alot about your problem, but it's still just guesswork on my part.

How do I make sure that people know email sent with postfix is valid?

Postfix isn't the issue, it's how you've configured postfix to "talk" with Google. I can send email from my postfix mailer to gmail all the time, and have done so for years.

Post the additional information needed to resolve this (log file info and/or headers from a sample email) so that we can get to the heart of the issue. Otherwise, it's all speculation, and will be nothing but guesswork.


Follow-up to comments

I don't think Postfix needs to talk to Google.

Either postfix connects directly to Google (which is how most SMTP deliveries are done), or you are using a relay to talk with Google (which is rare anymore). In the former, you need to have a correct MX and SPF setup, and a postfix main.cf that isn't borked. In the later, well, Google probably isn't going to take kindly to any email you send to a relay that doesn't have a SPF record that covers your originating server.

The third option is: you have found some magic internet vortex that relays email from server to server without the two servers ever talking to each other. I am doubtful of this.

Further more I fail to see why I should allow incoming 25 if i'm not accepting incoming email (except for bounces which i'm choosing to ignore because each email address has to be registered)

Because you'll break email in general.

I'm not one to repeat myself, but...

Post the additional information needed to resolve this (log file info and/or headers from a sample email) so that we can get to the heart of the issue. Otherwise, it's all speculation, and will be nothing but guesswork.

share|improve this answer
    
I don't think Postfix needs to talk to Google. Further more I fail to see why I should allow incoming 25 if i'm not accepting incoming email (except for bounces which i'm choosing to ignore because each email address has to be registered) –  Rook May 3 '10 at 19:03

Take this Email server test. It will tell you probable reasons for your emails being considered as SPAM and how to fix the same.

If the fixes cannot be implemented for some reason, use a SMTP Relay Service.

share|improve this answer

Simple- you do not send them from your machine.

Here are some issues that may mark it as spam:

  • You send for a gmail.com domain- but your IP address is not allowed to do so, which the recipient may check (SPF record in the gmail.com domain).
  • Your IP address has no proper bakcward DNS setting for the domain and is not a MX for the domain
  • Your IP Address is from a dynamic IP Address range which some anti spam settings can figure out (reverse DNS Name in a specific standard format) and thus blocked per definition.

Postfix has nothing to do with it. Depending on your domain you can / have to put in proper entries and move away from your end user dynamic IP (get a small VPX acting as relay), or - in case of an external domain - understand there is nothing you can do, as you abuse the provider domain.

TECHNICALLY are a spammer - like every other bot infected computer trying to send email from home connected computers for domains not properly matching up with the IP address.

share|improve this answer
    
(+1) I'm sending mail from a dedicated host. I've added my root domain name to the mx records and I've created spf records for every mx record. Now, I'm waiting for dns to propagate. –  Rook Apr 3 '10 at 17:52
    
Btw this never fixed my problem. Google is doing something strange. –  Rook May 3 '10 at 0:28
    
Google id soing nothing strange. Put up a test here. Did you put in the SPF records? They did fix it for me. –  TomTom May 3 '10 at 5:00

@TomTom I disagree. Postfix does have a play in the equation, although not postfix specifically, any SMTP server that can send mail has the potential to send it "wrong". For example, I would check the headers to make sure the from is correct (not yourname@hostname.domain.tld), and the from/reply to are the same. I know MSN for a fact is VERY PICKY when it comes to email not sent from a big business entity. Also, people have good reasons for using their own server to send mail, as in mailing lists.

And actually if he was sending from a dynamic IP, the mail wouldn't go through at all, which I completely disagree with, and would be bounced back to him. At least in my experiences.

I would defiantly check the links that Srikrishnan Chitoor posted, because the block of IPs that you are on could have been blacklisted. And again, which I don't believe in because if a "spammer" wants to be removed from said list all they have to do is pay but that is a whole different issue.

I would open up port 25 with SMTP auth. This way you can at least get the bouncebacks. But, that is up to you.

share|improve this answer
    
So you do not disagree - postfix does not play into the equation, as you say "every server can send it wrong". –  TomTom May 3 '10 at 5:00

Are SenderID, DomainKeys and DKIM properly set? Have a look at this blog post http://www.digitalsanctuary.com/tech-blog/debian/setting-up-spf-senderid-domain-keys-and-dkim.html

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.