Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

We have a Macintosh OS10.6 server and a big storage system accessible via SMB.

Right now we can mount partitions, but when we mount them they are only accessible to the user that did the mount. All other users get "Access Denied."

It there any straightforward way to mount so that all users will be able to access the files? (We want all users mapped to a single SMB UID.)

share|improve this question
1  
What's the client OS? –  Ignacio Vazquez-Abrams Apr 5 '10 at 17:17
    
@Ignacio Vazquez-Abrams: I believe he's stating that he's mounting the SMB shares on the Mac OS 10.6 server, to make them available to all users of the OS X 10.6 server. –  Josh Apr 5 '10 at 18:24
    
So then is the SMB server a *nix machine running Samba? –  Ignacio Vazquez-Abrams Apr 5 '10 at 18:43
    
@Ignacio, Yes, Mac OS X is Unix based. You can think of it as being roughly FreeBSD-like, with some things pulled from other *BSDs, and plenty of Apple additions and modifications. And yes, the SMB server for Mac OS X, in both the client and Server distributions of Mac OS X, is Samba. The SMB client in both distributions is based on Boris Popov's smbfs from FreeBSD. –  Spiff Apr 5 '10 at 21:12
    
@vy32, I'd like to point out that if the clients are Macs and the server is a Mac, the best practice is to use AFP rather than SMB. Since AFP grew up with Mac OS, the filesystem semantics it provides map better to operations Mac OS X needs to do. ("Better" compared to SMB or NFS or WebDAV or any other remote filesystem mounting protocol.) There should be no problem sharing the same sharepoints via both AFP and SMB, which is common when you want to support both Mac and non-Mac clients. –  Spiff Apr 5 '10 at 21:15
show 3 more comments

2 Answers 2

up vote 1 down vote accepted

In the mount_smbfs man page, it lists the answer. Do what Josh recommended, but use the following command instead:

sudo mount_smbfs -f0777 -d0777 //user@server/sharename /Volumes/Share\ Name\ Here

share|improve this answer
add comment

Have you tried mounting the share as the root user? In the terminal, try:

sudo mkdir -p /Volumes/Share\ Name\ Here
sudo mount -t smbfs //user@server/sharename /Volumes/Share\ Name\ Here

For more information see: http://www.macosxhints.com/article.php?story=20020610225855377

share|improve this answer
    
Sadly, this doesn't work. The files on the remote share are visible to the root user but not to other users. –  vy32 Apr 17 '10 at 12:51
    
What are the permissions on /Volumes/Share\ Name\ Here? What if you do sudo chmod 777 /Volumes/Share\ Name\ Here before sudo mount...? –  Josh Apr 17 '10 at 13:47
    
Thanks for the thoughts. I tried that, it doesn't work. Something in the OS is blocking UIDs other than the one that does the mount. –  vy32 May 5 '10 at 4:10
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.