Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I have tester.php file which I want to run on the browser and I have created symlink to it in my public_html folder, but still when I try to run it, its not working and gives me following error message.

Access forbidden!

You don't have permission to access the requested object. It is either read-protected or not readable by the server.

If you think this is a server error, please contact the webmaster.
Error 403
web.upc03.dev.com
Sun Apr 4 22:41:23 2010
Apache 

I am not sure as to why am I getting this error message, I have check all file permissions settings and it seems to be fine.

My File permissions settings are:

lrwxrwxrwx  for tester.php

Is there something that should be done other way or is this not the proper approach ?

share|improve this question
add comment

migrated from stackoverflow.com Apr 6 '10 at 1:19

This question came from our site for professional and enthusiast programmers.

1 Answer

The FollowSymlinks option needs to be enabled for that location/directory.

share|improve this answer
    
How can this be enabled. Actually we just changed our development server and I just did scp to copy all files and folder from one dev server to another dev server. Is there any internal settings which needs to be set for the implementations. Would really appreciate if you can provide some details as am not sure how to activate it. –  Rachel Apr 5 '10 at 2:51
    
rachel it isn't php internal setting but apache's settings, check apache conf. –  TheOsp Apr 5 '10 at 3:08
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.