Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

I want to allow a group (eg. 'BackupManagers') who can only preform backup and restore operations on certain databases. When creating the BackupManagers user account I checked db_backupoperator.

When the user logs in to create a backup they get an error message similar to the following when the select Tasks -> Backup -> Click on Add in the destiantion block -> click on the "..." button to browse

TITLE: Locate Database Files - MYSERVER\SQL2005 E:\MSSQL\Backup Cannot access the specified path or file on the server. Verify that you have the necessary security privileges and that the path or file exists.

If you know that the service account can access a specific file, type in the full path for the file in the File Name control in the Locate dialog box.

I have confirmed that the user has permissions to the folder. I have even created a share to this folder and had them access it through explorer. They are able to create and delete files within the folder.

I have found that if they type in the path to the file instead of using the "..." button to browse the directory tree then they can create a backup file fine.

Why is the browse button not working as expected?

Thanks!

share|improve this question

3 Answers 3

Does the "BackupManagers" group have any sort of permissions on the E: drive and E:\MSSQL folder? If not, they may require "traverse" permissions on those folders, or you could give the group "Bypass traverse checking" rights in Windows. The latter setting is done through group or local policies in the User Rights Assignment.

share|improve this answer

Make sure the account that the SQL server service is running under has access to the share as well.

share|improve this answer
    
Thanks for the reply, however I have confirmed that the account that SQL server is running as has this permission. When I log in from my workstation as the administrator I am able to browse to this directory. If it was a service issue it would be affecting me as well since the same service account is being used. –  Richard West Apr 6 '10 at 16:30

You much add USERS group in the security of the source/target folder of backup. Rightclick on the forlder, select computer name, ... and add USERS.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.