Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I built myself a linux-based NAS. It has several drives of various sizes and ages in an LVM configuration, with 800GB or so of data. The data is served using a simple samba server.

This was working flawlessly, but after physically moving it, it has developed a strange fault: Whenever I do something on the server to cause disk activity, the entire machine freezes hard. This has the effect of killing any open network connections to the box, and generally making it useless.

If I leave the machine for a few minutes it seems to come right again, but obviously this isn't really a solution.

There are no error or warning messages in syslog, or the kernel logs. If I power the machine on, and leave it, it runs for several days without locking up. After that time I stopped testing.

It doesn't freeze instantly - obviously it doesn't freeze while booting, and I can normally log in via SSH and start poking around in a few log files for a couple of minutes before it dies.

My question is:

What diagnostic tests can I run to determine the casuse?

share|improve this question
    
Do you see any console messages? –  Fred Apr 6 '10 at 17:39
    
No error messages of any kind :( –  Thomi Apr 6 '10 at 18:58
    
Did you figure it out, what caused system hang during disk activity ? –  user110995 Feb 16 '12 at 22:45

1 Answer 1

The typicall way to debug these kind of issues is a Debug kernel set to output to the com port. You connect another computer to the port and read the logs. That way you can get a feed of what happens when the system freezes. But it sounds like it's some kind of driver/hardware problem, and those can be very very hard to debug.

share|improve this answer
    
95% of the time I run into this problem description it ends up being at least one hard drive that's encountering correctable (through multiple retries) errors. :-( –  Brian Knoblauch Apr 6 '10 at 19:42
    
I would also suspect the HD or controller, but it's hard to pinpoint it. Replacing the HD and see what happens is obviously an option. –  pehrs Apr 7 '10 at 7:11
    
Well, right now my priority is to get the data off to safety as soon as possible. I might hack up a quick rsync script to retry every 30 minutes on failure, and see how that goes... –  Thomi Apr 7 '10 at 8:48

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.