Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I added Linux boxes to /etc/hosts.equiv and .rhosts file for rsh connectivity to an HP box. I am able to do rsh as root from Linux to HP. But if I run in a root shell as different user connection times out. Any reason?

share|improve this question

migrated from stackoverflow.com Apr 6 '10 at 22:29

This question came from our site for professional and enthusiast programmers.

    
rsh -l <username> <hostid> "hostname" –  kadeshpa Apr 7 '10 at 13:21

1 Answer 1

Try running rsh with the "-l" option to specify username or try

rsh user@hostname

If you don't it will default to the user you are currently logged in as.

share|improve this answer
7  
Also, obligatory finger-wagging about using ssh instead of rsh. WAGWAG* –  Cory J Apr 6 '10 at 22:51
    
Cannot use ssh for its complicated to set up in our environment. –  kadeshpa Apr 7 '10 at 13:22
1  
I don't see how ssh could be more complicated to set up than rsh... Thankfully, those are not my servers. –  Hubert Kario Oct 2 '10 at 19:56

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.