Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

I have spent the afternoon trying to install the mod_proxy module into apache.

I have tried

./configure --prefix=/opt/apache2 --enable-proxy --enable-proxy-http

./configure --prefix=/opt/apache2 --enable-module=proxy

After it finishes installing, navigating to /opt/apache2/modules only shows one file: httpd.exp.

It seems that the module is not being installed.

Any help is appreciated.

Thanks.

share|improve this question

migrated from stackoverflow.com Apr 7 '10 at 1:24

This question came from our site for professional and enthusiast programmers.

1  
Any particular reason why you didn't take the current SRPM, replace the tarball, and rebuild? mod_proxy seems to be standard in the package. –  Ignacio Vazquez-Abrams Apr 7 '10 at 3:05
1  
Further, there's very few sane reasons to rebuild apache these days, the distributions packages on the major distributions are very good, and they'll get the security updates you're likely to forget. –  LapTop006 Apr 7 '10 at 12:18

1 Answer 1

./configure --enable-proxy=static will build mod_proxy linked statically into the resulting httpd executable; this is the default if you specify ./configure --enable-proxy. ./configure --enable-proxy=shared is necessary to build the module as a loadable shared library.

Similarly, ./configure --enable-modules=proxy will link mod_proxy statically into the executable, while ./configure --enable-mods-shared=proxy will cause it to be built as a shared library. See the Apache configure documentation for more details.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.