Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I am trying to debug a virtual machine (VM) running on a remote computer from my workstation (A). Both VM and A are running Windows 7 Enterprise.

Apparently, I need to start the Remote Debugger Service (RDS) on VM as an administrator.

Apparently, I also need to run RDS as the user Tewr logged in on A (domain: DOM).

VM runs the services i need to debug, as well as the remote desktop interface with an account VMUSER in a domain called VMDOMAIN.

I manage to start RDS as administrator, but then the RDS process is owned by VMUSER and that's not good enough. I also manage to run RDS as DOM\Tewr, but then not as an administrator. I have Added DOM\Tewr as an administrator on VM, but thats not good enough becuase the process is still not run as administrator.

How can I run the RDS process as DOM\Tewr and "As Administrator", while logged on in windows as VMDOMAIN\VM?

(note: I have tried creating an account with the same credentials / password as VMUSER, as hinted in the ms article above, but with no luck...)

share|improve this question
add comment

2 Answers

up vote 1 down vote accepted

You need to configure auto-elevation for members of the local administrators group or make the user Tewr a member of the Domain Admins group. By default on Windows 7 (and Vista\W2k8) only the local Administrator account (the one with the S-1-5-21..500 SID) or members of the Domain Admins Group automatically elevate.

If you don't want to add the test user account to Domain Admins for this exercise then you can modify the default behaviour by GPO - What you want to do is change "User Account Control: Run all administrators in Admin Approval Mode" - you can find details on how to do this here.

share|improve this answer
    
I did not manage to "configure auto-elevation for members of the local administrators group", cause I couldnt find out how, but changing "User Account Control: Run all administrators in Admin Approval Mode" to "disabled" did the trick. Thanks! –  Tewr Apr 8 '10 at 11:36
    
sorry my answer wasn't clear - changing that setting is how you configure auto-elevation behavior for general administrators. –  Helvick Apr 8 '10 at 21:04
add comment

Perhaps psexec tool from sysinternals might be able to resolve your issue.

Here is the link.

http://technet.microsoft.com/en-us/sysinternals/bb897553.aspx

I used this tool for similar task but you might want to check it out. HTH.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.