Server Fault is a question and answer site for system and network administrators. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I'm more of a web developer kind of guy with limited knowledge of networks, so if anyone can point in the right direction, I would be grateful.

I am replacing my satellite connection with a T1 I got for a good deal thru the phone company. I also managed to get my hands on a Netvanta 3200 router. My problem is I can't quite figure out how to set up the router and can't find any kind of guide that would explain what I need to set where.

I'm not sure what to do next on my troubleshooting journey.

-- Currently I have a Visio doc from the phone company that lists my ip range as /29 Then it notes some Cisco 1721 with a .74 next to it and that has a line drawn to FairPoint Internet router with a .73 next to it.

Above that there is my circuit id, and an ip address that is

In the netvanta I have the interface setup using ppp encapsulation and have tried all the ips listed above. The ppp interface just does not seem to connect..

Output from netvanta:

Displaying interfaces...
t1 1/1 is DOWN
  Transmitter is sending remote alarm
  Receiver is getting AIS
  T1 coding is B8ZS, framing is ESF
  Clock source is internal, FDL type is AT&T
  Line build-out is 0dB
  No remote loopbacks, No network loopbacks
  Acceptance of remote loopback requests enabled
  Tx Alarm Enable: rai
  Last clearing of counters 00:04:21
    loss of frame  : 1, current duration 00:04:21
    loss of signal : 0
    AIS alarm      : 3, current duration 00:03:04
    Remote alarm   : 0

  DS0 Status: 123456789012345678901234
  Status Legend: '-' = DS0 is unallocated
                 'N' = DS0 is dedicated (nailed)

  Line Status: -- Red -- Blue -- Tx Yellow --

  5 minute input rate 0 bits/sec, 0 packets/sec
  5 minute output rate 0 bits/sec, 0 packets/sec
  Current Performance Statistics:
    7 Errored Seconds, 0 Bursty Errored Seconds
    4294967293 Severely Errored Seconds, 261 Severely Errored Frame Seconds
    264 Unavailable Seconds, 0 Path Code Violations
    53438 Line Code Violations, 0 Controlled Slip Seconds
    4 Line Errored Seconds, 0 Degraded Minutes

  TDM group 1, line protocol is DOWN
  Encapsulation PPP (ppp 1)
    0 packets input, 0 bytes, 1 no buffer
    0 runts, 5 giants, 0 throttles
    2989 input errors, 132 CRC, 1460 frame
    1396 abort, 0 discards, 0 overruns
    0 packets output, 0 bytes, 0 underruns

ppp 1 is DOWN
    Keep-alive is set (10 sec.)
    No multilink
      MTU = 1500
    No authentication
    IP is configured
  Link thru t1 1/1 is DOWN; LCP state is INITIAL
    Receive: bytes=0, pkts=0, errors=0
    Transmit: bytes=0, pkts=0, errors=0
    5 minute input rate 0 bits/sec, 0 packets/sec
    5 minute output rate 0 bits/sec, 0 packets/sec
  Bundle information
    Queueing method: weighted fair
    HDLC tx ring limit: 0
    Output queue: 0/0/428/64/0 (size/highest/max total/threshold/drops)
      Conversations  0/0/256 (active/max active/max total)
      Available Bandwidth 1152 kilobits/sec
share|improve this question
You should probably elaborate on your exact state right now and what you have done or tired. That way someone has a basis to start writing something to help you. – Frank V Apr 7 '10 at 18:13
up vote 0 down vote accepted

Your output indicates that you are receiving AIS alarm as well as a Loss of Framing. This would usually indicate that the NTE (network termination equipment/smartjack) the phone company installed is providing all ones on the customer DS1 side due to not receiving a signal from the central office. You probably will need to contact your phone company and find out if they have turned up the access port on their end to provide connectivity yet.

share|improve this answer
Thanks.. noting those errors got me a bit further with the phone company techs. The problem is on their end and they are now trying to troubleshoot it. – user39964 Apr 7 '10 at 19:44

Are you sure they are done with the install? It sounds like you might have ordered some sort of managed service that included a Cisco 1721 which will handle the T1 termination. Usually the T1 is installed (extended to customer premise) then the router is delivered. Once you have the router, a tech comes onsite to do the install, or you call the phone company to perform the activation yourself. Obviously, you could be providing your own hardware which may or may not be the case here.

Either way, I have never seen a T1 install that did not require an activation call.

I would call the phone company up and specifically order a managed service, which means they provide the T1 and router, and their techs control and manage the router. You just end up with an ethernet connection and an IP range. This is by far the best way to go if you are not familiar configuring T1s or routers.

share|improve this answer
...Not just "best way to go," in my opinion, but I would not accept (pay the bills for) a service in which they didn't set it up initially and prove it worked - nomatter who ended up buying the hardware. Usually you buy the hardware from the vendor as a part of the installation / set-up cost, which is sometimes waived, especially for more expensive services like T1. – Richard T Apr 7 '10 at 18:55
+1 for the activation call AND the managed services -- If you've never done the T1 thing it's going to give you a massive headache the first time. It definitely sounds like your line isn't fully set up/activated yet. – voretaq7 Apr 7 '10 at 18:58
Not a managed service, and they just admitted the Cisco was an oversight and intended for another client. Something is wrong with it on their end and they will call me back when working.. – user39964 Apr 7 '10 at 19:48

I agree with Doug Luxem.

I wish to add that, as you are unfamilliar with networking, note that T1 is a BATTERY AND UPS BACKED SERVICE so it should survive power outages of nearly any length.

To take advantage of the best your new service has to offer, be sure to get a battery backup solution for ALL equipment on your end that can stay up for long periods, too.

I accomplish this by taking a standard UPS unit and removing the batteries that came with and replacing them with appropriate voltage but VASTLY LARGER CAPACITY batteries. In particular, most units take either 12V or 24V batteries. I use AGM technology, deep-cycle batteries primarily marketed for mobile home and boat use...

Good luck.

share|improve this answer
Rather than hacking a commodity UPS I would suggest investing in a quality rackable/extendable unit sized for your load. More money, but worth it IMO because you'll get nice features like SNMP runtime monitoring (this is a different discussion, but an important one :-) – voretaq7 Apr 7 '10 at 19:06
voretaq7, who said anything about "comodity?" I use TWO rack-mounted UPS units with TWO large 12v Optima yellow-top (deep cycle) AGM batteries. I have a calculated capacity of something like 20 hours of backup time - WAY beyond what the standard rack-mount batteries are / were capable of - and I can change them cheaply. I got the two rack-mounted units used - they had dead batteries and were free! You can't beat that! I've been doing this for a few months short of 14 years and so far have only had to change the batteries once. I test to 10 hours, by the way. Never a failure yet... – Richard T Apr 7 '10 at 19:47
P.S. because these are rack-mount ("professional") UPS units, they have all the bells and whistles like run-time monitoring, warnings, etc. - I agree that these are nice features to have. – Richard T Apr 7 '10 at 19:50

You need info and configuration on both sides of the T1. Did the phone company just install the line and say "Have a nice day"? My recommendation would be to talk to the rep who sold you the T1 and find out what the next steps are for getting it set up.

share|improve this answer
Pretty much.. I updated my question with a little more info.. All they gave me was a visio doc with a few ip addresses – user39964 Apr 7 '10 at 18:28 is your interface's network block

the .73 should be your interface/PPP IP the .74 should be the remote end (these may be switched, but, I would assume they are using a cisco on their side) would be the Ethernet interface on your router

Once you are able to ping .73 and .74 and from the router can ping something like (google DNS resolver), then you can set up your default route of to point to .74

Based on the above, it looks like you set your interface to .72, which is the network address for the /30 they have assigned rather than the .73. Once you set the interface to .73 I think you would have it configured correctly.

Briefly, they assigned you .72/30. .72 is your network address, .73 is one interface, .74 is the other interface, .75 is the broadcast address for that netblock. Smallest netblock that can be allocated and is used to do point to point like this. You could do ip unnumbered, but, with that diagram, they are using a /30. From there, you have your /29 for your local network.

The fact that you're getting AIS and framing errors tells me that you're not getting a signal from the other side. It is possible that the phone company ran the T1, but, hasn't done the final crossconnect/virtual crossconnect at the central office. It is also possible that they did the remote end and still have to do the local end or some line conditioning along the way.

Did they say they were done? Based on what you're showing, it seems like they have only installed the remote end.

share|improve this answer
Thanks for the info, it does clear things up a bit. They had said they were done, but I called them back and something is wrong on their end. 3rd parties never seem to get things right for me on the first go round. – user39964 Apr 7 '10 at 19:51

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.