Server Fault is a question and answer site for system and network administrators. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

This is an installation on ModWest's shared hosting. I have enabled both PDO and PDO_sqlite on the server and phpinfo() verifies both are running. When I access PDO itself, I'm fine, and getting a meaningful error.

  $dbh = new PDO("");

This gives me an "Invalid Connection String" error.

But, as soon as I begin a connection string with sqlite:, I get a total crash. When I run via the webserver, I'm seeing NO error. When I enter a nonexistant filename, PHP does indeed create the file.

I tried running the constructor via CLI and there I do get a simple error:

Segmentation Fault

I'm not seeing ANYTHING in the PHP 5.2.6 changelogs about this bug. Anyone have any additional troubleshooting steps?

The OS is Debian 5.0.4

share|improve this question
up vote 1 down vote accepted

Looks like it came from enabling PDO and pdo_sqlite but NOT sqlite itself.

share|improve this answer

Is the server running Zend? Zend 3.3.9? Ioncube?

One or the other of those is probably not the latest version which causes a segfault due to an invalid jump address.

share|improve this answer
You mean Zend Optimizer? Yes, it is. The version is not shown. – danieltalsky Apr 7 '10 at 21:55
check the /etc/php5/apache2/php.ini file (or the equivalent for your distribution) and it should show the current version in the line that says zend_optimizer.version= Or, create a page with phpinfo() and look for the line that says with Zend Optimizer v3.3.3, Copyright (c) 1998-2007, by Zend Technologies – deleted Apr 8 '10 at 1:41

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.