Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I have a Dell PowerEdge 1850 server and a gigabit switch that supports nic teaming (and was configured to do so). The server has a total of four Intel PRO/1000 MT ports, which also support teaming.

But.. for some reason Intel does not actually have a version of the drivers/ProSet that will work for these cards on 2008 R2. You have to use the built-in drivers that come with 2008 R2, which do not support the additional features. According to their website, they have no plans to change this.

Strangely enough, I experimented with various drivers in an attempt to force it to work. At one point, the teaming was working, but there were side effects (such as the DNS server refusing to start).

So now I am back to running just one of the cards, (very) frustrated about the whole situation.

I have looked all over to see if there is some way around this, but have not had any success.

I know I can probably just get a new network adapter for it, but with the good deal I got, that would cost more than the server! :)

While staying with 2008 R2, does anyone know of any possible alternatives?

Thanks!

share|improve this question
    
Hmm... I had a similar experience with Windows teaming and DNS not starting. Someone said to make DNS a dependency of the teaming service, but I haven't tried it yet. –  Kyle Brandt Apr 8 '10 at 3:03
add comment

7 Answers

SOLUTION FOUND

  1. Download the Intel Networking solutions CD v15.3 from here: http://downloadcenter.intel.com/Detail_Desc.aspx?agr=Y&ProdId=879&DwnldID=19002&lang=eng
  2. Extract the files
  3. Use device manager to update the drivers for the Intel Pro1000 MT NICs. I had to do each independently.
  4. You can now run the ProSet install from V15.3_CD\APPS\PROSETDX\Winx64\ProSetDX.msi and it will succeed.
  5. You will now see the TABS for Teaming etc in the properties of the NIC via Device Manager.
share|improve this answer
    
This is how I configure teaming, too. Once done, you should see 2 Gbps on the networking tab of task manager (if your team consists of 2 physical nics). –  jftuga Jan 5 '11 at 14:50
add comment

http://downloadcenter.intel.com/SearchResult.aspx?lang=eng&ProductFamily=Network+Connectivity&ProductLine=Intel%c2%ae+Server+Adapters&ProductProduct=Intel%c2%ae+PRO%2f1000+MT+Server+Adapter

not sure if this has the management suite or not!

if this doesn't work then what are the results of

wmic nic get name

do this with the command prompt and paste the results here

share|improve this answer
    
Well when I visit that link, and choose 2008 R2, there are no downloads available. It says they are in-box, meaning - use the ones it automatically installs. Or did you mean to point to another link? I will try that when I am back at the system tomorrow. Currently I have it just connected to a single nic with the standard drivers. I have to cross my fingers and sing a chant to get the other ones (that even show bridging as an option) to install. Which option did you want me to run that command with? –  Klaus Apr 8 '10 at 4:23
    
you have to scroll down the screen! –  tonyr roth Apr 8 '10 at 4:23
    
oh darn blew this one bad sorry about that –  tonyr roth Apr 8 '10 at 4:24
    
ok after totally blowing this! have you tried the 08 version it has teaming. I'd probably install the teaming software then use the inbox nic drivers! good luck –  tonyr roth Apr 8 '10 at 4:32
    
I have not found a version of ProSet that would install without first checking the cards in the system to see if they are supported. So I cannot install the in-box drivers and get ProSet to see them it seems. –  Klaus Apr 9 '10 at 1:13
add comment

I stumbled upon this page looking for a way to make my Pro/1000 MT dual-port adapter support vlan tagging in Windows 7 Enterprise.

I tried everything manual device driver install, setting gpedit.msc to allow newer drives, ProSet for Vista and x64. Nothing I could do would enable me to see those extra tabs labelled "VLANS" and other. Including some WMI launch service.

Through in a Pro/1000 PT into my PC, installed ProSet and voila, the tabs are there.

Just signed up to advise anyone else wading through all the materials to get this to work. Order a PT card and you'll rest well.

Now back to esxi 5.1 testing.

share|improve this answer
add comment

If you really want to get exotic, you could install VMWare ESXi on the server and then run Windows as a virtual machine. ESXi would then handle all of the teaming and failover on the NIC for you and present a single network interface to Windows.

share|improve this answer
    
Appreciate the suggestion - but for all that I would prefer to just install another version of Server - not that I want to do that either, assuming it would even help :) –  Klaus Apr 8 '10 at 4:23
add comment

since it's Dell: http://support.dell.com/support/downloads/download.aspx?c=us&cs=555&l=en&s=biz&releaseid=R118839&SystemID=PWE_1850&servicetag=&os=WS8R2&osl=en&deviceid=8465&devlib=0&typecnt=0&vercnt=1&catid=-1&impid=-1&formatcnt=0&libid=5&typeid=-1&dateid=-1&formatid=-1&fileid=157739

If that doesn't help - you can always try and call their support

share|improve this answer
    
I had found that before. Unfortunately that download is for DOS :) Intel_LAN_9.0_DOS_Utilities_A00.exe –  Klaus Apr 9 '10 at 1:12
add comment

Here you can find the full driver zip file that you need to do the workaround. http://www.opendrivers.com/driver/2124291/intel-pro-1000-mt-driver-15.4-windows-all-linux-freebsd-free-download.html

Download that, use Windows device manager to update the drivers to what is on there, then install Proset from the apps dir.

share|improve this answer
add comment

PROWinx64, run, do not click OK on the message saying that there are no cards in the server

Copy pft6D16.tmp from temp folder

Then exit the installer & manually install drivers from pft6D16.tmp\PRO1000\Winx64\NDIS61

Hope this helps

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.